summaryrefslogtreecommitdiff
path: root/x11-libs/libdrm/libdrm-2.4.82.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
commit88ebe56470c37b02a044e1091cad6b2df0f3be8f (patch)
treed80b2d9337c01c4a0fe11a2ef9691fc3153ed6d3 /x11-libs/libdrm/libdrm-2.4.82.ebuild
parent4645b6f17f0da81e9fe84081fb126a37102ba153 (diff)
gentoo resync : 11.05.2018
Diffstat (limited to 'x11-libs/libdrm/libdrm-2.4.82.ebuild')
-rw-r--r--x11-libs/libdrm/libdrm-2.4.82.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/x11-libs/libdrm/libdrm-2.4.82.ebuild b/x11-libs/libdrm/libdrm-2.4.82.ebuild
deleted file mode 100644
index 00588bdc7a77..000000000000
--- a/x11-libs/libdrm/libdrm-2.4.82.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-XORG_MULTILIB=yes
-inherit xorg-2
-
-DESCRIPTION="X.Org libdrm library"
-HOMEPAGE="https://dri.freedesktop.org/"
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/mesa/drm.git"
-else
- SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.bz2"
-fi
-
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
-for card in ${VIDEO_CARDS}; do
- IUSE_VIDEO_CARDS+=" video_cards_${card}"
-done
-
-IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
-RESTRICT="test" # see bug #236845
-
-RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
- video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- valgrind? ( dev-util/valgrind )"
-
-src_prepare() {
- if [[ ${PV} = 9999* ]]; then
- # tests are restricted, no point in building them
- sed -ie 's/tests //' "${S}"/Makefile.am
- fi
- xorg-2_src_prepare
- epatch_user
-}
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS=(
- # Udev is only used by tests now.
- --disable-udev
- --disable-cairo-tests
- $(use_enable video_cards_amdgpu amdgpu)
- $(use_enable video_cards_exynos exynos-experimental-api)
- $(use_enable video_cards_freedreno freedreno)
- $(use_enable video_cards_intel intel)
- $(use_enable video_cards_nouveau nouveau)
- $(use_enable video_cards_omap omap-experimental-api)
- $(use_enable video_cards_radeon radeon)
- $(use_enable video_cards_tegra tegra-experimental-api)
- $(use_enable video_cards_vc4 vc4)
- $(use_enable video_cards_vivante etnaviv-experimental-api)
- $(use_enable video_cards_vmware vmwgfx)
- $(use_enable libkms)
- # valgrind installs its .pc file to the pkgconfig for the primary arch
- --enable-valgrind=$(usex valgrind auto no)
- )
-
- xorg-2_src_configure
-}