summaryrefslogtreecommitdiff
path: root/x11-libs/libdesktop-agnostic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-libs/libdesktop-agnostic
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-libs/libdesktop-agnostic')
-rw-r--r--x11-libs/libdesktop-agnostic/Manifest5
-rw-r--r--x11-libs/libdesktop-agnostic/libdesktop-agnostic-0.3.92-r1.ebuild51
-rw-r--r--x11-libs/libdesktop-agnostic/metadata.xml11
3 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/libdesktop-agnostic/Manifest b/x11-libs/libdesktop-agnostic/Manifest
new file mode 100644
index 000000000000..95d3b7d33657
--- /dev/null
+++ b/x11-libs/libdesktop-agnostic/Manifest
@@ -0,0 +1,5 @@
+DIST libdesktop-agnostic-0.3.92.tar.gz 442653 SHA256 8a77ec9f299acecdf38a0f106675667a392d314ac33f4e9be84fb696488dd354 SHA512 c383a45edb6a1fed1b1a13ed583627eceda444519276a5d62a8442bcdc1be5e7d37a0449b678e2ccfcf7441648ca6bff6c40e5930dbec9221182657201671e90 WHIRLPOOL e5c8abfe11cd602a0f0a3116acd464348b1975a370435ed3bb7527f1c33af5f0d66d0f9c3824354ff3e2a2608bc98dc4a6504ab49769b225d72dc1c1d168e367
+EBUILD libdesktop-agnostic-0.3.92-r1.ebuild 1375 SHA256 c069ff4d1afd646eabfc20ef9bc45cdb0d6db55a950890007f8c3975ad6d03cc SHA512 0350d6b739aae086845e24b46ac1860a9bb8481745f3982385c601243be21c5d7879a6472afcffaecf00498e18ddd6454b636d82450880a69a6fef283c4c9d51 WHIRLPOOL 34bd552eeaa8603cfc1dfcc8ee41602e357255c78c0504f379f415f0446135818833270080dd6ed325be6c01c054c68b09866a57d27fd646cf89d9425d5ab58a
+MISC ChangeLog 3262 SHA256 d4624f10a4537f681e7689b10d61c2bbc79749052d075f555b091a7ab1e3d9c9 SHA512 734df3aa51ebd6eb756cf07f4fbe5b7a0d57dcf45eb93d9296934f02b5d2c8080ef9499f39ab8822de7e22ae51b458d6a330f3bab19505c84e47cc67dad30106 WHIRLPOOL 362a803b19aa20fe59293be22233613ec945420a83921f2366acbb3d150cee72997269539ec6b894b31d5c22c77c91e488793ccdc7b4d94989208ee91b18686c
+MISC ChangeLog-2015 1813 SHA256 54006607c7fe9f4d5c8aa584a0df9bbdc94c56d067e7724b719acb809b3e8557 SHA512 8351ac41859ac90e1d10e23fb394d2999c304a632b4f2b6c37849283ea34eef699abe37e9ae3234b4d7aa9fce63eb99cea541247f6ecb790c80f7c72366f3595 WHIRLPOOL e25f815478182cef1e54b44b08f8d1dd8aceb466d016af65fab621e3e91562d3be59a60566bea37a3e07472720f511b16d5779bc7dd8f9f5d06aeb5497ddcfd1
+MISC metadata.xml 410 SHA256 aac8dfb7bb9d452a53e9dba49ba636403709c10adba4925a58e4d4b3e60050c0 SHA512 8957d3d8b720e4d51c28bad1637ab6de0d25feb656a0be4d5335c34ba9955e857e79945a5904650f26423a5e8b8e49563b9d46c52c70a0fb834a74b577169b0e WHIRLPOOL d3f0361c2e4032cb11ae36fd58c6e2f28c9c6d209b7a605441de1099ffa28860e2b0700fc809dbc92db798c8894bf4f995364a6c7110eb013dd5a29c6cf78158
diff --git a/x11-libs/libdesktop-agnostic/libdesktop-agnostic-0.3.92-r1.ebuild b/x11-libs/libdesktop-agnostic/libdesktop-agnostic-0.3.92-r1.ebuild
new file mode 100644
index 000000000000..c587c4404e12
--- /dev/null
+++ b/x11-libs/libdesktop-agnostic/libdesktop-agnostic-0.3.92-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+VALA_USE_DEPEND="vapigen"
+
+inherit python-single-r1 waf-utils vala
+
+DESCRIPTION="A desktop-agnostic library for GLib-based projects"
+HOMEPAGE="https://launchpad.net/libdesktop-agnostic"
+SRC_URI="https://launchpad.net/${PN}/0.4/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +gconf glade gnome +introspection"
+
+RDEPEND=">=dev-libs/glib-2
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ gconf? ( gnome-base/gconf:2 )
+ glade? ( gnome-base/libglade:2.0 )
+ gnome? ( gnome-base/gnome-desktop:2 )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/gobject-introspection
+ introspection? ( x11-libs/gtk+:2[introspection] )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_configure() {
+ local cfg="keyfile" fdo="glib" myconf=""
+
+ use gconf && cfg="gconf,${cfg}"
+ use gnome && fdo="${fdo},gnome"
+ use debug && myconf="${myconf} --enable-debug"
+ use glade && myconf="${myconf} --with-glade"
+ use introspection || myconf="${myconf} --disable-gi"
+
+ waf-utils_src_configure \
+ --sysconfdir="${EPREFIX}"/etc \
+ --config-backends=${cfg} \
+ --desktop-entry-backends=${fdo} \
+ --vfs-backends=gio \
+ ${myconf}
+}
diff --git a/x11-libs/libdesktop-agnostic/metadata.xml b/x11-libs/libdesktop-agnostic/metadata.xml
new file mode 100644
index 000000000000..0bc19fc83076
--- /dev/null
+++ b/x11-libs/libdesktop-agnostic/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="gconf">Enable GConf as configuration backend</flag>
+ <flag name="glade">Install the Glade catalog for the desktop-agnotstic GTK widgets.</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">libdesktop-agnostic</remote-id>
+ </upstream>
+</pkgmetadata>