summaryrefslogtreecommitdiff
path: root/x11-libs/libast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-17 06:56:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-17 06:56:15 +0000
commit1536d928ae095e00db8775fecca580c10adc0af8 (patch)
treece87fe174db749dca9fac4dcd229d263a03f47c4 /x11-libs/libast
parent0e33d150b98b9f2354c92788ef9dc739850b40f6 (diff)
gentoo auto-resync : 17:11:2022 - 06:56:15
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/Manifest3
-rw-r--r--x11-libs/libast/files/libast-0.8-configure-clang16.patch65
-rw-r--r--x11-libs/libast/libast-0.8-r1.ebuild (renamed from x11-libs/libast/libast-0.8.ebuild)9
3 files changed, 74 insertions, 3 deletions
diff --git a/x11-libs/libast/Manifest b/x11-libs/libast/Manifest
index 4af5e2f27ed5..6bffe2ba4794 100644
--- a/x11-libs/libast/Manifest
+++ b/x11-libs/libast/Manifest
@@ -1,5 +1,6 @@
+AUX libast-0.8-configure-clang16.patch 1956 BLAKE2B cd1e42815f636409e55c30e9da5ae9daf3b3b6411d7ed77eef41c90d3c621914393622102d6b7bccdda7d9e8348f38991c077cb94cba2f8b28611b45c3f94427 SHA512 c83bcea1d891cc46a090e3fa809a64c02ca14cf6606f40a1dfd7143629bd6a3d53e5f3bea36e9cc0569244d0bfe34e9122753aa6ad0349f9a42e3b48b270a52d
DIST libast-0.7.tar.gz 508654 BLAKE2B 0c5bf31d5b73fe11d4665bc0d8e1c9a987b944fcdcd89106a47ebf01eb90c2895b3e74e39874b360e91f027b8beaf5698363e9920ad879bfd241b13ef0232870 SHA512 0af1d508af88ce0a2f29fe7841e23759be7c6540a1e2698980c289245ba284fdbf76c593e457c0cd6cfc54dcb6d891b01a3fd4d4a6ecc511fb2de698c9a3046d
DIST libast-0.8.tar.gz 254188 BLAKE2B 02fc2872218f11cb4083d451377fdc46369c2ef7d1f0e547831dfdf4ecec2cd6aaf3453e9e8ef8431fbd5e3cd75e828e3c5967a6311853e7e87f583ef2be72c8 SHA512 266a479fdbfc479e233675fa7623488135c633fed9cb236ec0cee578fc5be83b88a2dbda8a304ee3a27384c96e93a4bdf40f60597660e09841380e0930dd93d9
EBUILD libast-0.7-r2.ebuild 874 BLAKE2B 67bd80db9c435a627497c57ba87ba5da08a675a8ee6d18911c69f215e0dad6af9535dfe91897d72ef9b254d163f59f9a22bbe39e1c2bb99d113a18d16e642d98 SHA512 3929b2100fc1149d860519b34eb42a36e05e9d5146d2b3ef2acb1173eb3265895526f7764699b4c02d21c1b20c627d506b475e5dc55be84d2c853248e9148c78
-EBUILD libast-0.8.ebuild 955 BLAKE2B 22dcbb6a97548918de58b473778042374cae59167c81a189c37b408a6e5ccb598edc3596939a2fd9ee664112094309538259f183d7aef04ac5e47eaac071d70f SHA512 30f84dbc64d8e9f187efa4e8c800e81de73ca694db761913b03af87b53dba2adc655aacb7b60f4b319b8ebf9d56354e60bd6e5083dfc511cef20734e8f87dbf3
+EBUILD libast-0.8-r1.ebuild 1018 BLAKE2B 28cda9fa5b29842d71dc1aedd54adb070d7dee1950f52a969c00e46a61200e1d1475d6b141b0cc06100ed479e8d912a783ce6920f584f660f91fcbb2f96712e2 SHA512 57a7f33a480010c67b3456fc6e8a44d56ac55f5a2bb8396add2d2ff37fcaec2605dd5d98168b14349028f4e512d31bc127022fa738367019a7b78bd8af98bc03
MISC metadata.xml 823 BLAKE2B 2b89b024a4867ac7dacd136f1aa57523f7d74947c8d93ce92231c9b0f58e73f2dbdc67bc82c40a9dacdab4722f37bdf002f766ff194f94b8c2245cee1cdf61f4 SHA512 ce3a1ed303a48743b3f419415a7ed1b0947865127ca75fc23f3e2155c21d7d9e63a7df782f69655d144c86631bcb26af910d5cba079ae6d0a71135061940dee6
diff --git a/x11-libs/libast/files/libast-0.8-configure-clang16.patch b/x11-libs/libast/files/libast-0.8-configure-clang16.patch
new file mode 100644
index 000000000000..3d339a2aeb34
--- /dev/null
+++ b/x11-libs/libast/files/libast-0.8-configure-clang16.patch
@@ -0,0 +1,65 @@
+https://github.com/mej/libast/pull/5
+https://bugs.gentoo.org/871705
+
+From 6c50760566499ef34cfd34ee38945e2612f4f7bf Mon Sep 17 00:00:00 2001
+From: Ryan Schmidt <git@ryandesign.com>
+Date: Mon, 7 Dec 2020 01:34:46 -0600
+Subject: [PATCH] Fix implicit declaration of library function exit
+
+--- a/libast.m4
++++ b/libast.m4
+@@ -505,10 +505,10 @@ char ovbuf[7];
+ int i;
+ for (i=0; i<7; i++) ovbuf[i]='x';
+ snprintf(ovbuf, 4,"foo%s", "bar");
+-if (ovbuf[5]!='x') exit(1);
++if (ovbuf[5]!='x') return 1;
+ snprintf(ovbuf, 4,"foo%d", 666);
+-if (ovbuf[5]!='x') exit(1);
+-exit(0);
++if (ovbuf[5]!='x') return 1;
++return 0;
+ } >>
+ changequote([, ])
+ , dps_cv_snprintf_bug=0, dps_cv_snprintf_bug=1, dps_cv_snprintf_bug=2)
+@@ -550,10 +550,10 @@ int main(void)
+ char ovbuf[8] = "xxxxxxx";
+ int i;
+ prnt(ovbuf, "foo%s", "bar");
+- if (ovbuf[5]!='x') {fprintf(stderr, "buffer: %s\n", ovbuf); exit(1);}
++ if (ovbuf[5]!='x') {fprintf(stderr, "buffer: %s\n", ovbuf); return 1;}
+ prnt(ovbuf, "foo%d", 666);
+- if (ovbuf[5]!='x') {fprintf(stderr, "buffer: %s\n", ovbuf); exit(1);}
+- exit(0);
++ if (ovbuf[5]!='x') {fprintf(stderr, "buffer: %s\n", ovbuf); return 1;}
++ return 0;
+ } >>
+ changequote([, ])
+ , dps_cv_vsnprintf_bug=0, dps_cv_vsnprintf_bug=1, dps_cv_vsnprintf_bug=2)
+@@ -651,10 +651,10 @@ AC_DEFUN([dps_rlimit_nproc], [
+ AC_TRY_RUN(
+ changequote(<<, >>)dnl
+ <<
+-#ifndef HAVE_STDLIB_H
++#ifdef HAVE_STDLIB_H
+ #include <stdlib.h>
+ #endif /* HAVE_STDLIB_H */
+-#ifndef HAVE_SIGNAL_H
++#ifdef HAVE_SIGNAL_H
+ #include <signal.h>
+ #endif /* HAVE_SIGNAL_H */
+ #ifdef HAVE_UNISTD_H
+@@ -699,10 +699,10 @@ AC_DEFUN([dps_rlimit_memlock], [
+ AC_TRY_RUN(
+ changequote(<<, >>)dnl
+ <<
+-#ifndef HAVE_STDLIB_H
++#ifdef HAVE_STDLIB_H
+ #include <stdlib.h>
+ #endif /* HAVE_STDLIB_H */
+-#ifndef HAVE_SIGNAL_H
++#ifdef HAVE_SIGNAL_H
+ #include <signal.h>
+ #endif /* HAVE_SIGNAL_H */
+ #ifdef HAVE_UNISTD_H
+
diff --git a/x11-libs/libast/libast-0.8.ebuild b/x11-libs/libast/libast-0.8-r1.ebuild
index 396c0cb77b4d..a508619651b6 100644
--- a/x11-libs/libast/libast-0.8.ebuild
+++ b/x11-libs/libast/libast-0.8-r1.ebuild
@@ -16,16 +16,21 @@ IUSE="imlib cpu_flags_x86_mmx pcre"
RDEPEND="
!sci-astronomy/ast
+ media-libs/freetype
x11-base/xorg-proto
x11-libs/libXt
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
- media-libs/freetype
imlib? ( media-libs/imlib2 )
- pcre? ( dev-libs/libpcre )"
+ pcre? ( dev-libs/libpcre )
+"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8-configure-clang16.patch
+)
+
src_prepare() {
default