summaryrefslogtreecommitdiff
path: root/x11-libs/libXaw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
commit48dbe17904ac8ee6f006488d8f21734b0d253db4 (patch)
tree90c7f087cbefd4ac6b893072d309e75dbf019f76 /x11-libs/libXaw
parent7972abc05090180dcc09d2b16af4020ce1cd1841 (diff)
gentoo auto-resync : 17:03:2023 - 00:25:50
Diffstat (limited to 'x11-libs/libXaw')
-rw-r--r--x11-libs/libXaw/Manifest2
-rw-r--r--x11-libs/libXaw/libXaw-1.0.15.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/libXaw/Manifest b/x11-libs/libXaw/Manifest
index 386be641410e..25ba8fe379e0 100644
--- a/x11-libs/libXaw/Manifest
+++ b/x11-libs/libXaw/Manifest
@@ -1,3 +1,5 @@
DIST libXaw-1.0.14.tar.bz2 690994 BLAKE2B 9beaf5ad47b300b3bd57c85ce4c54996db824cb10377472bab8b4ec446458ce162b21e19c4e3ed8d48f10d0bddb695509e73d3274326bdd59916dfbb3c63120e SHA512 29d1c151369523ae6cb418e636b0b7b39ccccc35462a0b394dbeb46d5b6d780badd2eb872a55d9fbba1ee1af034e76c0463f40f8d8a7be2c336d08b3b1bf81d4
+DIST libXaw-1.0.15.tar.xz 589832 BLAKE2B a176b59fbbd7555e7ec2f114a31e9ed804c0ee9e2f7f0efc1ed836caa280947bbe1c66dc4b5155f983a91b649a6303730377b5203d17dcd6af8dfdfa51e7784c SHA512 8edbf280b7b24b9040c291545053c1251d6af7e7f56da43a6065a1848245863eb52bdfc28c2f18dbb6597a4064394a44f4df5d8596a1a467549ccc9ce50a7821
EBUILD libXaw-1.0.14.ebuild 884 BLAKE2B 376a003a6262cb0d01b0d0640c398f57198166f96e85edebd16636c2527bb66d26f65a5a884884c06ce48f7b65ab14f546a808bf7cf45d5c47b66155ddbe6e66 SHA512 f5c48e4791a5d413691f377cb15d5d6a52cb1c39e8580ce0ce9cda12967b943cb6ebfbe4d35fb1964c497dbfaa54f18aa752d27ff55c2cb77503bbc58344dde4
+EBUILD libXaw-1.0.15.ebuild 916 BLAKE2B ae0965f65fa3ad4ab73950097f9f5d85853d288ea03d64674501c58b6ede56ca3710c56d089e892704a8fd5a481b3f8426b7db0a756490f35183c4a5119d2c33 SHA512 e9f1f385d334b45d53811cf65d18f5dd9f56f07852c3f9148b51a3953cd5626b904247a7adf45d6f3ccdd561c06a9ffe5868147e1b88c0b9cebeb044d6517556
MISC metadata.xml 422 BLAKE2B b5d0b66e0f4638f8e8969f8fe1c02f4d83195f11529b266e2f79f18b71f2407102545a4e55b318c4a0957cbf00570586626a9a8ce3cda99bc463c0246ed7bcce SHA512 56d9ac54daf5febd8fc3df76ce86974b6ab37130bdb80d84ad07b59d985d6d1337afff0b36bafadad9ba464e7cbd45a7d6f71f697be3b66f9db907b317d9c2a8
diff --git a/x11-libs/libXaw/libXaw-1.0.15.ebuild b/x11-libs/libXaw/libXaw-1.0.15.ebuild
new file mode 100644
index 000000000000..9cd7d07a7490
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND="x11-base/xorg-proto
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}