summaryrefslogtreecommitdiff
path: root/x11-libs/libXaw/libXaw-1.0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-11 18:45:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-11 18:45:56 +0000
commit72d7e048ae88be323a380e2eae52dfda0b2dc1c0 (patch)
treee3d45f3a557c324e6058aae95f920e55d8f40602 /x11-libs/libXaw/libXaw-1.0.16.ebuild
parent8b4349b75818953123e2d4b80963181a9640c8e3 (diff)
gentoo auto-resync : 11:03:2024 - 18:45:56
Diffstat (limited to 'x11-libs/libXaw/libXaw-1.0.16.ebuild')
-rw-r--r--x11-libs/libXaw/libXaw-1.0.16.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-libs/libXaw/libXaw-1.0.16.ebuild b/x11-libs/libXaw/libXaw-1.0.16.ebuild
new file mode 100644
index 000000000000..22493f2c8cfc
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="deprecated"
+
+RDEPEND="
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}