summaryrefslogtreecommitdiff
path: root/x11-libs/libX11/libX11-1.8.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 19:39:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 19:39:10 +0100
commit3ba87279363a3a099c83d72faaf5b6bee1b23304 (patch)
tree7d4e3f6da46124be1284b7e40bb66a42b77eb846 /x11-libs/libX11/libX11-1.8.6.ebuild
parentdb70871b2044b9bfde346d6f4027dafb0a013c4c (diff)
gentoo auto-resync : 15:06:2023 - 19:39:09
Diffstat (limited to 'x11-libs/libX11/libX11-1.8.6.ebuild')
-rw-r--r--x11-libs/libX11/libX11-1.8.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-libs/libX11/libX11-1.8.6.ebuild b/x11-libs/libX11/libX11-1.8.6.ebuild
new file mode 100644
index 000000000000..28f7a5710fd8
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.8.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX=xz
+inherit toolchain-funcs xorg-3
+
+# Note: please bump this with x11-misc/compose-tables
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+
+ !<xfce-base/xfce4-settings-4.16.3
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans
+"
+BDEPEND="test? ( dev-lang/perl )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ --enable-ipv6
+ --without-fop
+ --with-keysymdefdir="${ESYSROOT}/usr/include/X11"
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -rf "${ED}"/usr/share/X11/locale || die
+}