summaryrefslogtreecommitdiff
path: root/x11-libs/libICE/libICE-1.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 07:50:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 07:50:47 +0000
commitef4d67f1907798e309efed58d673fd60594a14a8 (patch)
treede3ad0f65999c31df8a545f5d8918bae816e0a4c /x11-libs/libICE/libICE-1.1.1-r1.ebuild
parent30be4d7d2806b014770312920fcda743d4dc67d0 (diff)
gentoo auto-resync : 20:12:2022 - 07:50:47
Diffstat (limited to 'x11-libs/libICE/libICE-1.1.1-r1.ebuild')
-rw-r--r--x11-libs/libICE/libICE-1.1.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-libs/libICE/libICE-1.1.1-r1.ebuild b/x11-libs/libICE/libICE-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..8181872ecff1
--- /dev/null
+++ b/x11-libs/libICE/libICE-1.1.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Inter-Client Exchange library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+
+RDEPEND="
+ elibc_glibc? (
+ || ( >=sys-libs/glibc-2.36 dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans
+"
+
+XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ --disable-docs
+ --disable-specs
+ --without-fop
+)