summaryrefslogtreecommitdiff
path: root/x11-libs/gtkglarea/gtkglarea-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-libs/gtkglarea/gtkglarea-2.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-libs/gtkglarea/gtkglarea-2.1.0.ebuild')
-rw-r--r--x11-libs/gtkglarea/gtkglarea-2.1.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-libs/gtkglarea/gtkglarea-2.1.0.ebuild b/x11-libs/gtkglarea/gtkglarea-2.1.0.ebuild
new file mode 100644
index 000000000000..b27202dcb50b
--- /dev/null
+++ b/x11-libs/gtkglarea/gtkglarea-2.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="OpenGL canvas and context provider for GTK+"
+HOMEPAGE="http://www.mono-project.com/GtkGLArea"
+
+LICENSE="LGPL-2+ GPL-2+" # examples are GPL-2+, library is LGPL-2+
+SLOT="2"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.22:2
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not build examples
+ sed -e "s:\(SUBDIRS.*\)examples:\1:" \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README* docs/*.txt"
+ gnome2_src_install
+
+ if use examples; then
+ cd "${S}"/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins *.c *.h *.lwo README || die "doins failed"
+ fi
+}