summaryrefslogtreecommitdiff
path: root/x11-libs/fltk/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-18 06:49:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-18 06:49:50 +0000
commit529bbf6d047ac6b80c0d9310ec0f666c145ec5fe (patch)
treeae415fb3fee6b16f7371a5d3597dcf98cca19b62 /x11-libs/fltk/files
parentec33f4bcbd3944dc39c56a98cde12232684932cf (diff)
gentoo auto-resync : 18:03:2024 - 06:49:50
Diffstat (limited to 'x11-libs/fltk/files')
-rw-r--r--x11-libs/fltk/files/fltk-1.4.9999-cmake.patch19
-rw-r--r--x11-libs/fltk/files/fltk-1.4.9999-conf-tests.patch42
-rw-r--r--x11-libs/fltk/files/fltk-1.4.9999-makefile-dirs.patch14
-rw-r--r--x11-libs/fltk/files/fltk-1.4.9999-optim.patch13
4 files changed, 88 insertions, 0 deletions
diff --git a/x11-libs/fltk/files/fltk-1.4.9999-cmake.patch b/x11-libs/fltk/files/fltk-1.4.9999-cmake.patch
new file mode 100644
index 000000000000..3f576d501ece
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.4.9999-cmake.patch
@@ -0,0 +1,19 @@
+diff --git a/configure.ac b/configure.ac
+index 6b64110b0..1330d3f27 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1878,10 +1878,13 @@ dnl Set empty BINARY_DIR variable for fltk-config.in (CMake compatibility)
+ BINARY_DIR=
+ AC_SUBST([BINARY_DIR])
+
++INCLUDE_DIRS="${includedir}"
++AC_SUBST(INCLUDE_DIRS)
++
+ dnl Write all of the files...
+ AC_CONFIG_HEADERS([config.h:configh.in])
+ AC_CONFIG_HEADERS([FL/fl_config.h:fl_config.in])
+-AC_CONFIG_FILES([makeinclude fltk.list fltk-config fltk.spec FL/Makefile])
++AC_CONFIG_FILES([makeinclude fltk.list fltk-config fltk.spec FL/Makefile CMake/FLTKConfig.cmake])
+ AC_OUTPUT
+
+ dnl Make sure the fltk-config script is executable...
diff --git a/x11-libs/fltk/files/fltk-1.4.9999-conf-tests.patch b/x11-libs/fltk/files/fltk-1.4.9999-conf-tests.patch
new file mode 100644
index 000000000000..47db8d03c8d2
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.4.9999-conf-tests.patch
@@ -0,0 +1,42 @@
+diff --git a/Makefile b/Makefile
+index 2d99808d9..283f825dd 100644
+--- a/Makefile
++++ b/Makefile
+@@ -103,9 +103,6 @@ makeinclude: configure configh.in makeinclude.in
+ touch config.h
+ chmod +x fltk-config
+
+-configure: configure.ac
+- autoconf
+-
+ portable-dist:
+ epm -v -s fltk.xpm fltk
+
+diff --git a/documentation/Makefile b/documentation/Makefile
+index 0b176246b..882fbf8a4 100644
+--- a/documentation/Makefile
++++ b/documentation/Makefile
+@@ -91,12 +91,6 @@ install: $(MANPAGES)
+ $(INSTALL_DATA) fltk.pdf $(DESTDIR)$(docdir); \
+ fi
+ echo "Installing man pages in $(DESTDIR)$(mandir) ..."
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-options.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat3
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.$(CAT3EXT) $(DESTDIR)$(mandir)/cat3
+ -$(INSTALL_DIR) $(DESTDIR)$(mandir)/man1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.man $(DESTDIR)$(mandir)/man1/fluid.1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.man $(DESTDIR)$(mandir)/man1/fltk-config.1
+@@ -105,10 +99,6 @@ install: $(MANPAGES)
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.man $(DESTDIR)$(mandir)/man3/fltk.3
+
+ install-linux install-osx:
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/blocks.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/checkers.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/sudoku.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+ -$(INSTALL_DIR) $(DESTDIR)$(mandir)/man6
+ $(INSTALL_MAN) $(SRC_DOCDIR)/blocks.man $(DESTDIR)$(mandir)/man6/blocks.6
+ $(INSTALL_MAN) $(SRC_DOCDIR)/checkers.man $(DESTDIR)$(mandir)/man6/checkers.6
diff --git a/x11-libs/fltk/files/fltk-1.4.9999-makefile-dirs.patch b/x11-libs/fltk/files/fltk-1.4.9999-makefile-dirs.patch
new file mode 100644
index 000000000000..e49aa7408cca
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.4.9999-makefile-dirs.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile b/Makefile
+index c02de0972..2d99808d9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,8 +16,7 @@
+
+ include makeinclude
+
+-DIRS = $(IMAGEDIRS) $(LIBDECORDIR) src $(CAIRODIR) $(FLUIDDIR) fltk-options test \
+- documentation
++DIRS = $(IMAGEDIRS) $(LIBDECORDIR) src $(CAIRODIR) fltk-options
+
+ all: makeinclude fltk-config
+ for dir in $(DIRS); do\
diff --git a/x11-libs/fltk/files/fltk-1.4.9999-optim.patch b/x11-libs/fltk/files/fltk-1.4.9999-optim.patch
new file mode 100644
index 000000000000..a1e18bbb74b2
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.4.9999-optim.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 1330d3f27..c76dba26f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1552,7 +1552,7 @@ AS_IF([test -n "$GCC"], [
+ AS_IF([test "x$with_optim" != x], [
+ OPTIM="$with_optim $OPTIM"
+ ], [
+- OPTIM="-Os $OPTIM"
++ OPTIM="$OPTIM"
+ ])
+ ])
+