summaryrefslogtreecommitdiff
path: root/x11-libs/fltk/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-libs/fltk/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-libs/fltk/files')
-rw-r--r--x11-libs/fltk/files/FLTKConfig.cmake37
-rw-r--r--x11-libs/fltk/files/fltk-1.3.0-share.patch39
-rw-r--r--x11-libs/fltk/files/fltk-1.3.2-conf-tests.patch55
-rw-r--r--x11-libs/fltk/files/fltk-1.3.2-desktop.patch19
-rw-r--r--x11-libs/fltk/files/fltk-1.3.2-jpeg-9a.patch22
-rw-r--r--x11-libs/fltk/files/fltk-1.3.3-fl_open_display.patch10
-rw-r--r--x11-libs/fltk/files/fltk-1.3.3-fltk-config.patch14
-rw-r--r--x11-libs/fltk/files/fltk-1.3.3-makefile-dirs.patch11
-rw-r--r--x11-libs/fltk/files/fltk-1.3.3-visibility.patch22
-rw-r--r--x11-libs/fltk/files/fltk-1.3.3-xutf8-visibility.patch165
-rw-r--r--x11-libs/fltk/files/fltk-1.3.4-conf-tests.patch55
11 files changed, 449 insertions, 0 deletions
diff --git a/x11-libs/fltk/files/FLTKConfig.cmake b/x11-libs/fltk/files/FLTKConfig.cmake
new file mode 100644
index 000000000000..09427aac2aa5
--- /dev/null
+++ b/x11-libs/fltk/files/FLTKConfig.cmake
@@ -0,0 +1,37 @@
+#-----------------------------------------------------------------------------
+#
+# FLTKConfig.cmake - FLTK CMake configuration file for external projects.
+#
+# This file is configured by FLTK and used by the UseFLTK.cmake module
+# to load FLTK's settings for an external project.
+
+# The FLTK source tree.
+# SET(FLTK_SOURCE_DIR "@FLTK_SOURCE_DIR@")
+
+# The FLTK include file directories.
+SET(FLUID_COMMAND "/usr/bin/fluid")
+SET(FLTK_EXECUTABLE_DIRS "/usr/bin")
+SET(FLTK_LIBRARY_DIRS "/usr/lib")
+SET(FLTK_LIBRARIES "fltk_images;fltk_gl;fltk_forms;fltk")
+SET(FLTK_INCLUDE_DIRS "/usr/include")
+
+# The C and C++ flags added by FLTK to the cmake-configured flags.
+SET(FLTK_REQUIRED_C_FLAGS "")
+SET(FLTK_REQUIRED_CXX_FLAGS "")
+
+# The FLTK version number
+SET(FLTK_VERSION_MAJOR "1")
+SET(FLTK_VERSION_MINOR "1")
+SET(FLTK_VERSION_PATCH "7")
+
+# Is FLTK using shared libraries?
+SET(FLTK_BUILD_SHARED_LIBS "ON")
+# SET(FLTK_BUILD_SETTINGS_FILE "@FLTK_BUILD_SETTINGS_FILE@")
+
+# The location of the UseFLTK.cmake file.
+SET(FLTK11_USE_FILE "/usr/share/cmake/Modules/FLTKUse.cmake")
+
+# # The ExodusII library dependencies.
+# IF(NOT FLTK_NO_LIBRARY_DEPENDS)
+# INCLUDE("@FLTK_LIBRARY_DEPENDS_FILE@")
+# ENDIF(NOT FLTK_NO_LIBRARY_DEPENDS)
diff --git a/x11-libs/fltk/files/fltk-1.3.0-share.patch b/x11-libs/fltk/files/fltk-1.3.0-share.patch
new file mode 100644
index 000000000000..af2092abc894
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.0-share.patch
@@ -0,0 +1,39 @@
+--- a/fluid/Makefile
++++ b/fluid/Makefile
+@@ -82,16 +82,16 @@ install: all
+ $(INSTALL_BIN) $(FLUID) $(DESTDIR)$(bindir)/fluid$(EXEEXT)
+
+ install-linux:
+- -$(INSTALL_DIR) $(DESTDIR)/usr/share/applications
+- $(INSTALL_DATA) fluid.desktop $(DESTDIR)/usr/share/applications
++ -$(INSTALL_DIR) $(DESTDIR)$(datadir)/applications
++ $(INSTALL_DATA) fluid.desktop $(DESTDIR)$(datadir)/applications
+ for size in 16 32 48 64 128; do \
+- if test ! -d $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps; then \
+- $(INSTALL_DIR) $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps; \
++ if test ! -d $(DESTDIR)$(datadir)/icons/hicolor/$${size}x$${size}/apps; then \
++ $(INSTALL_DIR) $(DESTDIR)$(datadir)/icons/hicolor/$${size}x$${size}/apps; \
+ fi; \
+- $(INSTALL_DATA) icons/fluid-$$size.png $(DESTDIR)/usr/share/icons/hicolor/$${size}x$${size}/apps/fluid.png; \
++ $(INSTALL_DATA) icons/fluid-$$size.png $(DESTDIR)$(datadir)/icons/hicolor/$${size}x$${size}/apps/fluid.png; \
+ done
+- -$(INSTALL_DIR) $(DESTDIR)/usr/share/mimelnk/application
+- $(INSTALL_DATA) x-fluid.desktop $(DESTDIR)/usr/share/mimelnk/application
++ -$(INSTALL_DIR) $(DESTDIR)$(datadir)/mimelnk/application
++ $(INSTALL_DATA) x-fluid.desktop $(DESTDIR)$(datadir)/mimelnk/application
+
+ install-osx:
+ echo Installing Fluid in $(DESTDIR)/Applications...
+@@ -109,9 +109,9 @@ uninstall:
+ $(RM) $(DESTDIR)$(bindir)/fluid$(EXEEXT)
+
+ uninstall-linux:
+- $(RM) $(DESTDIR)/usr/share/applications/fluid.desktop
+- $(RM) $(DESTDIR)/usr/share/icons/hicolor/*/fluid.png
+- $(RM) $(DESTDIR)/usr/share/mimelnk/application/x-fluid.desktop
++ $(RM) $(DESTDIR)$(datadir)/applications/fluid.desktop
++ $(RM) $(DESTDIR)$(datadir)/icons/hicolor/*/fluid.png
++ $(RM) $(DESTDIR)$(datadir)/mimelnk/application/x-fluid.desktop
+
+ uninstall-osx:
+ $(RM) -r $(DESTDIR)/Applications/fluid.app
diff --git a/x11-libs/fltk/files/fltk-1.3.2-conf-tests.patch b/x11-libs/fltk/files/fltk-1.3.2-conf-tests.patch
new file mode 100644
index 000000000000..74022a72ffb9
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.2-conf-tests.patch
@@ -0,0 +1,55 @@
+--- a/Makefile
++++ b/Makefile
+@@ -100,9 +103,6 @@
+ touch config.h
+ chmod +x fltk-config
+
+-configure: configure.in
+- autoconf
+-
+ config.guess config.sub:
+ -automake --add-missing 2> /dev/null
+ if [ ! -e config.sub ]; then echo NOTE: Using frozen copy of config.sub; cp misc/config.sub . ; fi
+--- a/documentation/Makefile
++++ b/documentation/Makefile
+@@ -84,11 +84,6 @@
+ $(INSTALL_DATA) fltk.pdf $(DESTDIR)$(docdir); \
+ fi
+ echo "Installing man pages in $(DESTDIR)$(mandir) ..."
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat3
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.$(CAT3EXT) $(DESTDIR)$(mandir)/cat3
+ -$(INSTALL_DIR) $(DESTDIR)$(mandir)/man1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.man $(DESTDIR)$(mandir)/man1/fluid.1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.man $(DESTDIR)$(mandir)/man1/fltk-config.1
+@@ -96,10 +91,6 @@
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.man $(DESTDIR)$(mandir)/man3/fltk.3
+
+ install-linux install-osx:
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/blocks.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/checkers.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/sudoku.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+ -$(INSTALL_DIR) $(DESTDIR)$(mandir)/man6
+ $(INSTALL_MAN) $(SRC_DOCDIR)/blocks.man $(DESTDIR)$(mandir)/man6/blocks.6
+ $(INSTALL_MAN) $(SRC_DOCDIR)/checkers.man $(DESTDIR)$(mandir)/man6/checkers.6
+@@ -108,17 +99,11 @@
+
+ uninstall:
+ $(RMDIR) $(DESTDIR)$(docdir)
+- $(RM) $(DESTDIR)$(mandir)/cat1/fluid.$(CAT1EXT)
+ $(RM) $(DESTDIR)$(mandir)/man1/fluid.1
+- $(RM) $(DESTDIR)$(mandir)/cat1/fltk-config.$(CAT1EXT)
+ $(RM) $(DESTDIR)$(mandir)/man1/fltk-config.1
+- $(RM) $(DESTDIR)$(mandir)/cat3/fltk.$(CAT3EXT)
+ $(RM) $(DESTDIR)$(mandir)/man3/fltk.3
+
+ uninstall-linux uninstall-osx:
+- $(RM) $(DESTDIR)$(mandir)/cat6/blocks.$(CAT6EXT)
+- $(RM) $(DESTDIR)$(mandir)/cat6/checkers.$(CAT6EXT)
+- $(RM) $(DESTDIR)$(mandir)/cat6/sudoku.$(CAT6EXT)
+ $(RM) $(DESTDIR)$(mandir)/man6/blocks.6
+ $(RM) $(DESTDIR)$(mandir)/man6/checkers.6
+ $(RM) $(DESTDIR)$(mandir)/man6/sudoku.6
diff --git a/x11-libs/fltk/files/fltk-1.3.2-desktop.patch b/x11-libs/fltk/files/fltk-1.3.2-desktop.patch
new file mode 100644
index 000000000000..ef72ba9c3ec2
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.2-desktop.patch
@@ -0,0 +1,19 @@
+--- a/fluid/fluid.desktop
++++ b/fluid/fluid.desktop
+@@ -6,5 +6,5 @@
+ Icon=fluid
+ Terminal=false
+ Type=Application
+-MimeType=application/x-fluid
++MimeType=application/x-fluid;
+ Categories=Development;GUIDesigner;
+--- a/fluid/x-fluid.desktop
++++ b/fluid/x-fluid.desktop
+@@ -1,6 +1,6 @@
+ [Desktop Entry]
+ Type=MimeType
+-MimeType=application/x-fluid
++MimeType=application/x-fluid;
+ Icon=fluid.png
+ Patterns=*.fl
+ Name=FLUID
diff --git a/x11-libs/fltk/files/fltk-1.3.2-jpeg-9a.patch b/x11-libs/fltk/files/fltk-1.3.2-jpeg-9a.patch
new file mode 100644
index 000000000000..ed487e7dc24d
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.2-jpeg-9a.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/479774
+
+--- a/src/Fl_JPEG_Image.cxx
++++ b/src/Fl_JPEG_Image.cxx
+@@ -155,7 +155,7 @@
+
+ jpeg_create_decompress(&dinfo);
+ jpeg_stdio_src(&dinfo, fp);
+- jpeg_read_header(&dinfo, 1);
++ jpeg_read_header(&dinfo, TRUE);
+
+ dinfo.quantize_colors = (boolean)FALSE;
+ dinfo.out_color_space = JCS_RGB;
+@@ -337,7 +337,7 @@
+
+ jpeg_create_decompress(&dinfo);
+ jpeg_mem_src(&dinfo, data);
+- jpeg_read_header(&dinfo, 1);
++ jpeg_read_header(&dinfo, TRUE);
+
+ dinfo.quantize_colors = (boolean)FALSE;
+ dinfo.out_color_space = JCS_RGB;
diff --git a/x11-libs/fltk/files/fltk-1.3.3-fl_open_display.patch b/x11-libs/fltk/files/fltk-1.3.3-fl_open_display.patch
new file mode 100644
index 000000000000..562f1157038f
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.3-fl_open_display.patch
@@ -0,0 +1,10 @@
+--- a/src/Fl_x.cxx
++++ b/src/Fl_x.cxx
+@@ -2211,6 +2211,7 @@
+ static int result = -1;
+
+ if (result == -1) {
++ fl_open_display();
+ result = 0;
+ unsigned long nitems;
+ unsigned long *words = 0;
diff --git a/x11-libs/fltk/files/fltk-1.3.3-fltk-config.patch b/x11-libs/fltk/files/fltk-1.3.3-fltk-config.patch
new file mode 100644
index 000000000000..ca7607afa4fc
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.3-fltk-config.patch
@@ -0,0 +1,14 @@
+--- a/fltk-config.in
++++ b/fltk-config.in
+@@ -42,9 +42,8 @@
+
+ # flags for C++ compiler:
+ ARCHFLAGS="@ARCHFLAGS@"
+-CFLAGS="@CFLAGS@ @LARGEFILE@ @PTHREAD_FLAGS@"
+-CXXFLAGS="@CXXFLAGS@ @LARGEFILE@ @PTHREAD_FLAGS@"
+-LDFLAGS="@LDFLAGS@"
++CFLAGS=" @LARGEFILE@ @PTHREAD_FLAGS@"
++CXXFLAGS=" @LARGEFILE@ @PTHREAD_FLAGS@"
+ LDLIBS="@LIBS@"
+ OPTIM="@OPTIM@"
+ CAIROFLAGS="@CAIROFLAGS@"
diff --git a/x11-libs/fltk/files/fltk-1.3.3-makefile-dirs.patch b/x11-libs/fltk/files/fltk-1.3.3-makefile-dirs.patch
new file mode 100644
index 000000000000..089855cefa6f
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.3-makefile-dirs.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@
+
+ include makeinclude
+
+-DIRS = $(IMAGEDIRS) src $(CAIRODIR) fluid test documentation
++DIRS = $(IMAGEDIRS) src $(CAIRODIR)
+
+ all: makeinclude fltk-config
+ for dir in $(DIRS); do\
diff --git a/x11-libs/fltk/files/fltk-1.3.3-visibility.patch b/x11-libs/fltk/files/fltk-1.3.3-visibility.patch
new file mode 100644
index 000000000000..491e0a18876d
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.3-visibility.patch
@@ -0,0 +1,22 @@
+--- a/src/Fl.cxx
++++ b/src/Fl.cxx
+@@ -928,7 +928,7 @@
+
+ ////////////////////////////////////////////////////////////////
+
+-Fl_Widget* fl_oldfocus; // kludge for Fl_Group...
++FL_EXPORT Fl_Widget* fl_oldfocus; // kludge for Fl_Group...
+
+ /**
+ Sets the widget that will receive FL_KEYBOARD events.
+--- a/FL/x.H
++++ b/FL/x.H
+@@ -114,7 +114,7 @@ FL_EXPORT Fl_Region XRectangleRegion(int x, int y, int w, int h); // in fl_rect.
+ // With Xlib / X11 fonts, fl_xfont will return the current selected font.
+ // With XFT / X11 fonts, fl_xfont will attempt to return the bitmap "core" font most
+ // similar to (usually the same as) the current XFT font.
+-class Fl_XFont_On_Demand
++class FL_EXPORT Fl_XFont_On_Demand
+ {
+ public:
+ Fl_XFont_On_Demand(XFontStruct* p = NULL) : ptr(p) { }
diff --git a/x11-libs/fltk/files/fltk-1.3.3-xutf8-visibility.patch b/x11-libs/fltk/files/fltk-1.3.3-xutf8-visibility.patch
new file mode 100644
index 000000000000..f30105e18c06
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.3-xutf8-visibility.patch
@@ -0,0 +1,165 @@
+--- a/src/xutf8/utf8Input.c
++++ b/src/xutf8/utf8Input.c
+@@ -18,6 +18,7 @@
+
+ #include <config.h>
+ #include "../Xutf8.h"
++#include "../../FL/Fl_Export.H"
+ #include <X11/X.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+@@ -53,7 +54,7 @@ typedef struct {
+ #include "lcUniConv/jisx0212.h"
+ #include "lcUniConv/ksc5601.h"
+
+-static int
++FL_EXPORT static int
+ XConvertEucTwToUtf8(char* buffer_return, int len) {
+ /* FIXME */
+ #if HAVE_LIBC_ICONV
+@@ -120,7 +121,7 @@ XConvertEucTwToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertEucKrToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -160,7 +161,7 @@ XConvertEucKrToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertBig5ToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -189,7 +190,7 @@ XConvertBig5ToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertCp936extToUtf8(char* buffer_return, int len)
+ {
+ int i = 0, l = 0;
+@@ -226,7 +227,7 @@ XConvertCp936extToUtf8(char* buffer_retu
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertGb2312ToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -261,7 +262,7 @@ XConvertGb2312ToUtf8(char* buffer_return
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertEucCnToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -300,7 +301,7 @@ XConvertEucCnToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertEucJpToUtf8(char* buffer_return, int len) {
+ int i = 0, l = 0;
+ char *buf;
+@@ -373,7 +374,7 @@ XConvertEucJpToUtf8(char* buffer_return,
+ return l;
+ }
+
+-static int
++FL_EXPORT static int
+ XConvertEucToUtf8(const char* locale,
+ char* buffer_return,
+ int len,
+@@ -408,7 +409,7 @@ XConvertEucToUtf8(const char* locale,
+ return len;
+ }
+
+-int
++FL_EXPORT int
+ XUtf8LookupString(XIC ic,
+ XKeyPressedEvent* event,
+ char* buffer_return,
+--- a/src/xutf8/utf8Utils.c
++++ b/src/xutf8/utf8Utils.c
+@@ -21,6 +21,7 @@
+ #if !defined(WIN32) && !defined(__APPLE__)
+
+ #include "../Xutf8.h"
++#include "../../FL/Fl_Export.H"
+
+ /*** NOTE : all functions are LIMITED to 24 bits Unicode values !!! ***/
+
+@@ -29,7 +30,7 @@
+ * Returns the byte length of the converted UTF-8 char
+ * Returns -1 if the UTF-8 string is not valid
+ */
+-int
++FL_EXPORT int
+ XConvertUtf8ToUcs(const unsigned char *buf,
+ int len,
+ unsigned int *ucs) {
+@@ -137,7 +138,7 @@ XConvertUcsToUtf8(unsigned int ucs,
+ * returns the byte length of the first UTF-8 char
+ * (returns -1 if not valid)
+ */
+-int
++FL_EXPORT int
+ XUtf8CharByteLen(const unsigned char *buf,
+ int len) {
+ unsigned int ucs;
+@@ -165,7 +166,7 @@ XCountUtf8Char(const unsigned char *buf
+ /*
+ * Same as XConvertUtf8ToUcs but no sanity check is done.
+ */
+-int
++FL_EXPORT int
+ XFastConvertUtf8ToUcs(const unsigned char *buf,
+ int len,
+ unsigned int *ucs) {
+--- a/src/xutf8/utf8Wrap.c
++++ b/src/xutf8/utf8Wrap.c
+@@ -20,6 +20,7 @@
+ #if !defined(WIN32) && !defined(__APPLE__)
+
+ #include "../Xutf8.h"
++#include "../../FL/Fl_Export.H"
+ #include <X11/Xlib.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+@@ -705,7 +706,7 @@ XUtf8_measure_extents(
+ /*****************************************************************************/
+ /** returns the pixel width of a UTF-8 string **/
+ /*****************************************************************************/
+-int
++FL_EXPORT int
+ XUtf8TextWidth(XUtf8FontStruct *font_set,
+ const char *string,
+ int num_bytes) {
+@@ -815,7 +816,7 @@ XUtf8TextWidth(XUtf8FontStruct *font_se
+ /*****************************************************************************/
+ /** get the X font and glyph ID of a UCS char **/
+ /*****************************************************************************/
+-int
++FL_EXPORT int
+ XGetUtf8FontAndGlyph(XUtf8FontStruct *font_set,
+ unsigned int ucs,
+ XFontStruct **fnt,
+@@ -886,7 +887,7 @@ XGetUtf8FontAndGlyph(XUtf8FontStruct *f
+ /*****************************************************************************/
+ /** returns the pixel width of a UCS char **/
+ /*****************************************************************************/
+-int
++FL_EXPORT int
+ XUtf8UcsWidth(XUtf8FontStruct *font_set,
+ unsigned int ucs) {
+
diff --git a/x11-libs/fltk/files/fltk-1.3.4-conf-tests.patch b/x11-libs/fltk/files/fltk-1.3.4-conf-tests.patch
new file mode 100644
index 000000000000..994df56ad361
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.3.4-conf-tests.patch
@@ -0,0 +1,55 @@
+--- a/Makefile
++++ b/Makefile
+@@ -100,9 +103,6 @@
+ touch config.h
+ chmod +x fltk-config
+
+-configure: configure.ac
+- autoconf
+-
+ config.guess config.sub:
+ -automake --add-missing 2> /dev/null
+ if [ ! -e config.sub ]; then echo NOTE: Using frozen copy of config.sub; cp misc/config.sub . ; fi
+--- a/documentation/Makefile
++++ b/documentation/Makefile
+@@ -84,11 +84,6 @@
+ $(INSTALL_DATA) fltk.pdf $(DESTDIR)$(docdir); \
+ fi
+ echo "Installing man pages in $(DESTDIR)$(mandir) ..."
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat3
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.$(CAT3EXT) $(DESTDIR)$(mandir)/cat3
+ -$(INSTALL_DIR) $(DESTDIR)$(mandir)/man1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.man $(DESTDIR)$(mandir)/man1/fluid.1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.man $(DESTDIR)$(mandir)/man1/fltk-config.1
+@@ -96,10 +91,6 @@
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.man $(DESTDIR)$(mandir)/man3/fltk.3
+
+ install-linux install-osx:
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/blocks.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/checkers.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/sudoku.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+ -$(INSTALL_DIR) $(DESTDIR)$(mandir)/man6
+ $(INSTALL_MAN) $(SRC_DOCDIR)/blocks.man $(DESTDIR)$(mandir)/man6/blocks.6
+ $(INSTALL_MAN) $(SRC_DOCDIR)/checkers.man $(DESTDIR)$(mandir)/man6/checkers.6
+@@ -108,17 +99,11 @@
+
+ uninstall:
+ $(RMDIR) $(DESTDIR)$(docdir)
+- $(RM) $(DESTDIR)$(mandir)/cat1/fluid.$(CAT1EXT)
+ $(RM) $(DESTDIR)$(mandir)/man1/fluid.1
+- $(RM) $(DESTDIR)$(mandir)/cat1/fltk-config.$(CAT1EXT)
+ $(RM) $(DESTDIR)$(mandir)/man1/fltk-config.1
+- $(RM) $(DESTDIR)$(mandir)/cat3/fltk.$(CAT3EXT)
+ $(RM) $(DESTDIR)$(mandir)/man3/fltk.3
+
+ uninstall-linux uninstall-osx:
+- $(RM) $(DESTDIR)$(mandir)/cat6/blocks.$(CAT6EXT)
+- $(RM) $(DESTDIR)$(mandir)/cat6/checkers.$(CAT6EXT)
+- $(RM) $(DESTDIR)$(mandir)/cat6/sudoku.$(CAT6EXT)
+ $(RM) $(DESTDIR)$(mandir)/man6/blocks.6
+ $(RM) $(DESTDIR)$(mandir)/man6/checkers.6
+ $(RM) $(DESTDIR)$(mandir)/man6/sudoku.6