summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-vesa
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 03:19:26 +0000
commitcaf79cb4f7c4d5f7cce488d8f50dfb98ddbd09ab (patch)
tree4fb39a9252efabe8f160ef46b7b3be2f52af25aa /x11-drivers/xf86-video-vesa
parent3606ceecb950b302a6ba2a9882aeeff2a851e5dc (diff)
gentoo auto-resync : 10:12:2022 - 03:19:26
Diffstat (limited to 'x11-drivers/xf86-video-vesa')
-rw-r--r--x11-drivers/xf86-video-vesa/Manifest2
-rw-r--r--x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-vesa/Manifest b/x11-drivers/xf86-video-vesa/Manifest
index 35e29050a988..aea4edba5d22 100644
--- a/x11-drivers/xf86-video-vesa/Manifest
+++ b/x11-drivers/xf86-video-vesa/Manifest
@@ -1,3 +1,5 @@
DIST xf86-video-vesa-2.5.0.tar.bz2 304322 BLAKE2B aee8b59d769a72fb2890bbadde7fb87e2f527fb58eaf8b2ef515b0a1b7dc591c6afaf1d8692caaaefb741f475ed77bc0ed069be43a752103260bc85314a7a830 SHA512 36fd921f54f33eb25966b5f9ea1e1b3e9009965c012c8b9c676686b472111719921b80cf62dafc746058878253e21f0ef341a2ff2d650df22ca1e35e81716a8b
+DIST xf86-video-vesa-2.6.0.tar.xz 275572 BLAKE2B 18a4aae9125c03da183aea07403c2e0809adf18c963c4acda8b55130a2a22c9fa1b0dc02dbb3ea836a4e735396a660a1e55bec6482707c019f9bfd756442d6b9 SHA512 494e117c1e6e0ce4c66ac7798de54667862c62605bfd76dd9373447d40dcd0521100810c9285cbe9c159440e217954c0cad6d5219c5894e075509c7c0bc353c7
EBUILD xf86-video-vesa-2.5.0.ebuild 623 BLAKE2B ab3420635068980df0be30496073d4b2917f89c67323a25af6356b56de3a0f75e535ccd9fb67518256b465d9706950d3e50d44b74733507084986232e9d98350 SHA512 ba18775c51b0c19c5cf368d11736543cac6cfecf1ea8176446d1cd2d791223ff8e62456b8bdb8535fc8756f92389e39087f6d58cc42af67cc9facf3c6fad3de3
+EBUILD xf86-video-vesa-2.6.0.ebuild 551 BLAKE2B 4977c13d74302d1ce7793e52bfd87983f0101ee82f1c3d93fab7e55a1e9773c9d94fe308ea43d86d8c079de10afb5c985dc0dc38f94146e0afb5ca9f6cc9b3a3 SHA512 c5872ef9238196ffa24f8b7171eeb185fd6a482b73d638a56a0bd74a5d585431ba90f1a4aef6df299bcb338021a591310f73c284f68dc69598fe58a151c015ca
MISC metadata.xml 349 BLAKE2B 0f62438da7f64ce6d8b6d7bdcaf97ad3065d2c7203f9e486e0862002a36c02f7cb07560848d20d6a7e349ff74ace198679affae82b4510dd464ed7027d23cbfb SHA512 f36c8c310d053c5246f313e89378ed38082683152cc56874fbf8863521de6f7eb4e3fdd0683c6d96cba726cc2789b5d69ad8712ec058dd10982e37e6f540f566
diff --git a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild
new file mode 100644
index 000000000000..a74450947e1d
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit linux-info xorg-3
+
+DESCRIPTION="Generic VESA video driver"
+KEYWORDS="-* ~alpha ~amd64 ~x86"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present DEVMEM; then
+ echo
+ ewarn "This driver requires /dev/mem support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Character devices --->"
+ ewarn " [*] /dev/mem virtual device support"
+ echo
+ fi
+}