summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild b/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
new file mode 100644
index 000000000000..0dce180b8afd
--- /dev/null
+++ b/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_DRI="always"
+inherit xorg-2
+
+DESCRIPTION="X.Org driver for VIA/S3G cards"
+HOMEPAGE="https://www.freedesktop.org/wiki/Openchrome/"
+LICENSE="MIT"
+
+KEYWORDS="amd64 x86"
+IUSE="debug viaregtool"
+
+RDEPEND=">=x11-base/xorg-server-1.9"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ x11-libs/libXvMC
+ x11-libs/libdrm
+"
+
+DOCS=( ChangeLog NEWS README )
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ $(use_enable debug xv-debug)
+ $(use_enable viaregtool)
+ )
+ xorg-2_src_configure
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ elog "Supported chipsets:"
+ elog "CLE266 (VT3122), KM400/P4M800 (VT3205), K8M800 (VT3204),"
+ elog "PM800/PM880/CN400 (VT3259), VM800/CN700/P4M800Pro (VT3314),"
+ elog "CX700 (VT3324), P4M890 (VT3327), K8M890 (VT3336),"
+ elog "P4M900/VN896 (VT3364), VX800 (VT3353), VX855 (VT3409), VX900"
+ elog
+ elog "The driver name is 'openchrome', and this is what you need"
+ elog "to use in your xorg.conf (and not 'via')."
+ elog
+ elog "See the ChangeLog and release notes for more information."
+}