summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild b/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
index b2f2a36914b7..1219380c354b 100644
--- a/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
+++ b/x11-drivers/xf86-video-openchrome/xf86-video-openchrome-0.6.0.ebuild
@@ -1,42 +1,41 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
XORG_DRI="always"
-inherit xorg-2
+inherit xorg-3
DESCRIPTION="X.Org driver for VIA/S3G cards"
HOMEPAGE="https://www.freedesktop.org/wiki/Openchrome/"
-LICENSE="MIT"
+LICENSE="MIT"
KEYWORDS="amd64 x86"
IUSE="debug viaregtool"
-RDEPEND=">=x11-base/xorg-server-1.9"
-DEPEND="
- ${RDEPEND}
+RDEPEND="
+ >=x11-base/xorg-server-1.9
x11-libs/libX11
x11-libs/libXext
- x11-libs/libXv
x11-libs/libXvMC
- x11-libs/libdrm
-"
-
-DOCS=( ChangeLog NEWS README )
+ x11-libs/libdrm"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libXv"
PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_configure() {
- XORG_CONFIGURE_OPTIONS=(
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable debug)
$(use_enable debug xv-debug)
$(use_enable viaregtool)
)
- xorg-2_src_configure
+ xorg-3_src_configure
}
pkg_postinst() {
- xorg-2_pkg_postinst
+ xorg-3_pkg_postinst
elog "Supported chipsets:"
elog "CLE266 (VT3122), KM400/P4M800 (VT3205), K8M800 (VT3204),"