summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-09 07:31:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-09 07:31:31 +0100
commit7b03fb00a2d749e09f83cb0ac3f351f006244586 (patch)
tree91dbee5032d1e8f9f7b3c2d7d7c198c3502a584f /x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild
parentc956c264bdc853972b72016b752683468881af25 (diff)
gentoo auto-resync : 09:10:2022 - 07:31:31
Diffstat (limited to 'x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild')
-rw-r--r--x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild
new file mode 100644
index 000000000000..401559b5c2d6
--- /dev/null
+++ b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+inherit udev xorg-3
+
+DESCRIPTION="VMWare mouse input driver"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --with-hal-bin-dir=/punt
+ --with-hal-callouts-dir=/punt
+ --with-hal-fdi-dir=/punt
+ --with-udev-rules-dir=$(get_udevdir)/rules.d
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -r "${ED}"/punt || die
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}