summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild')
-rw-r--r--x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
new file mode 100644
index 000000000000..4a0bb9479bb4
--- /dev/null
+++ b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit udev xorg-2
+
+DESCRIPTION="VMWare mouse input driver"
+IUSE=""
+KEYWORDS="amd64 x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-hal-bin-dir=/punt
+ --with-hal-callouts-dir=/punt
+ --with-hal-fdi-dir=/punt
+ --with-udev-rules-dir=$(get_udevdir)/rules.d
+ )
+
+ xorg-2_pkg_setup
+}
+
+src_install() {
+ xorg-2_src_install
+ rm -rf "${ED}"/punt
+}