summaryrefslogtreecommitdiff
path: root/x11-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-16 12:04:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-16 12:04:26 +0100
commitb92911550490e2da121ec4b02d3cf60a2d31a17d (patch)
treedc29e698da3b00d42ead3796b35416159e83d57a /x11-base
parent7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (diff)
gentoo auto-resync : 16:04:2024 - 12:04:26
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/Manifest.gzbin1558 -> 1558 bytes
-rw-r--r--x11-base/xcb-proto/Manifest2
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.17.0.ebuild49
3 files changed, 51 insertions, 0 deletions
diff --git a/x11-base/Manifest.gz b/x11-base/Manifest.gz
index 326cfe213c0e..71585e6c0156 100644
--- a/x11-base/Manifest.gz
+++ b/x11-base/Manifest.gz
Binary files differ
diff --git a/x11-base/xcb-proto/Manifest b/x11-base/xcb-proto/Manifest
index b6bd4070a36f..ae01d3db15ae 100644
--- a/x11-base/xcb-proto/Manifest
+++ b/x11-base/xcb-proto/Manifest
@@ -1,3 +1,5 @@
DIST xcb-proto-1.16.0.tar.xz 151612 BLAKE2B 1c59ae4c71e697bd4f0298f6e0ea5235fc47baa9cf584e079258f1da8be538d1b67dc45f1325d82495247d0f8020d0244ca334de3794b410a1feaceabd6b285e SHA512 54906f379a7aa2cbbfbbe54764c02dbf522ca8f6c54e07d4faae471aac3aee25d0359be38c808c8da887de228aed745582a78b2f56714b023bca8f3513b24972
+DIST xcb-proto-1.17.0.tar.xz 151748 BLAKE2B 0f46d040062fca4f6b598bdb7ab7a254b9aefce198812af82fd2112e06e88277e3c9e0a3bab161930b56688e71e1848bb859d4f33588f9496fe7399f9758b9a7 SHA512 34c3795e5a48a66d89b72ee1777fb0bede489d5ec07018e6c9ef3c13bdd60b0358fc2c04a1f0ed0acb5b681aeeb92033db579036e4f5edd967fe56714c03acdf
EBUILD xcb-proto-1.16.0.ebuild 1148 BLAKE2B 3eea55f25b87c04b88192fd06fe6ca76fe01897210490476abba3c56e005ebeb4333c1fde9f1e4ec7ec154325857b908ae55432f8139a1e5c8b21b1b74b3ae28 SHA512 6b42a2cac6580e766218d0b4e28751f098f0c4a86c676d1f265386ad2f533c2126f0e10ed2a77030a8eb556898157ca3c2fe2d0dfa86cdbc2911eb341568871a
+EBUILD xcb-proto-1.17.0.ebuild 1158 BLAKE2B c42ed8c5d96f7445dc6cac63cc00d2964316da904c383c2f0aaae2f7b6a5e0df122188e7eb93047df74f252715069dd25ce88926a39cdbd1daf32851f672e62a SHA512 e8b8564a1e5b440206acf6aa83f4f1a8d4cecb289cf85eeabd05fb46d089c1d7aeb8d76c56be1830a542d5348b207676699a2d0d9544eb6dfaf8214bf8672c4a
MISC metadata.xml 341 BLAKE2B 96e3b6613178261ab586ecc15cb98a7de1f752c081744d02ce3b9976a07e22056ff5c564b418839486d106964daa7327bb3d4d57b469593ac1b4968fbfc3bf67 SHA512 1374a7a6fb6254afa291f3ed7fbc0ff5aa1e478ad2b6df17dcf6969cfcce7681eeb2fb82caa6cbcab5109d2ffd128d3d18819013855a2a338bde5dd93992b6f1
diff --git a/x11-base/xcb-proto/xcb-proto-1.17.0.ebuild b/x11-base/xcb-proto/xcb-proto-1.17.0.ebuild
new file mode 100644
index 000000000000..a7af99861180
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.17.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+"
+
+ECONF_SOURCE="${S}"
+
+src_configure() {
+ # Don't use Python to find sitedir here.
+ PYTHON=true default
+}
+
+src_compile() {
+ :
+}
+
+xcbgen_install() {
+ # Use eclass to find sitedir instead.
+ emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
+ python_optimize
+}
+
+src_install() {
+ # Restrict SUBDIRS to prevent xcbgen with empty sitedir.
+ emake install DESTDIR="${D}" SUBDIRS=src
+ python_foreach_impl xcbgen_install
+}