summaryrefslogtreecommitdiff
path: root/x11-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-26 19:01:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-26 19:01:21 +0000
commit82fd88ea93e273f4b02580552f808b6305d1e840 (patch)
treeda485ff18e7c82cfdd34040e8c5c8a2712d565fe /x11-base
parente978c365080e8765f234868ad266cd333c53a94f (diff)
gentoo auto-resync : 26:03:2024 - 19:01:20
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/Manifest.gzbin1555 -> 1557 bytes
-rw-r--r--x11-base/xorg-proto/Manifest4
-rw-r--r--x11-base/xorg-proto/xorg-proto-2024.1.ebuild51
-rw-r--r--x11-base/xorg-proto/xorg-proto-9999.ebuild9
4 files changed, 57 insertions, 7 deletions
diff --git a/x11-base/Manifest.gz b/x11-base/Manifest.gz
index 9c5fccaa579a..d2d3abf1c8bc 100644
--- a/x11-base/Manifest.gz
+++ b/x11-base/Manifest.gz
Binary files differ
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index fbe2d14452f5..7ac220125d9a 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1,4 +1,6 @@
DIST xorgproto-2023.2.tar.xz 759040 BLAKE2B ff255b91770ad11cdcc48d12815317285d8d16d28011a86166f3e07af18b30fdf35c2eb7b6537504eb4c0e9ca65b3116493422b6faebe04ee80e6aee92387675 SHA512 af0a8c8094fc6a490a886a8c048175762b6334798f2e48b6f6e19a7bb39ddbef05fa1237c4e9d9f1d870d24f5ca7a7c463044c41ceebd108f8ab0816677a582d
+DIST xorgproto-2024.1.tar.xz 760500 BLAKE2B a3850f8594e8b4240f731dce696c3ab8310c3b2419117dea3141a093a690d9bc16652e64eb5516073145309c65327bd14be2eaa8843c04de25c8eff6c46d3c1d SHA512 63955cb604ff831575af2193548857c1b99e52d00206ea9421ce99e145094bcd907388c4574bc32174a01cbe2c940b0377bf75ae7d2c0f953157dc9c32e5a07f
EBUILD xorg-proto-2023.2.ebuild 1159 BLAKE2B 97ea5322f2ee61de021c80fbb65867ba29b0fd0fd171630ae8438710367175846c56da1fab6c4e14a4076b710502c208cd3244ea9cdd0090a98b4193389b36e2 SHA512 e9fcae335f5205f8e1c684d24b692247d4a7526fee0c14c566943b86f0c27ab5fd65411dc31dcbb8e5ad41a376e6947f29d1119d63348da22cada2b0028542b3
-EBUILD xorg-proto-9999.ebuild 1178 BLAKE2B 7140656979f5c32bb39976d7755c903feba848b5dbc8e67732d6d44ee239b60bc156eb4a60984f9d2c83fb9e6a35d2d523ec276beca380e157622d29543a3080 SHA512 7bd0a0409bb0e183fe5a08bbe000fac2ffcd4e5105d24746fa23cf1f361591d9460267efb786e15cdae7b181725cf579a4d4524b1439ad6ad7e814d4d8daf206
+EBUILD xorg-proto-2024.1.ebuild 1152 BLAKE2B ce0a6edbb34f340c94cf0a210fe7231e555e8f2d579d8c79746286e18ff79f4edcce30dc7b0a16a6e2e279f1fc1eb26032a4ca3a5fd89954beebfa7c9090a901 SHA512 8fd883a9eebb9f84c09c93473fb3ba42964bbc4f592a8993bdc25ea98984c54917fb8031db377cf1915555c9012d46eb2bf222f66b316ae07aa42f5b33b38180
+EBUILD xorg-proto-9999.ebuild 1152 BLAKE2B ce0a6edbb34f340c94cf0a210fe7231e555e8f2d579d8c79746286e18ff79f4edcce30dc7b0a16a6e2e279f1fc1eb26032a4ca3a5fd89954beebfa7c9090a901 SHA512 8fd883a9eebb9f84c09c93473fb3ba42964bbc4f592a8993bdc25ea98984c54917fb8031db377cf1915555c9012d46eb2bf222f66b316ae07aa42f5b33b38180
MISC metadata.xml 342 BLAKE2B 86fa6d992d56d65a60c04ece61c97dcdd3cb0807dd7d895d907d83fe78427df05b15b5924d7b96a38164003e11a7de78470829c72238acfa35473d2f536b5363 SHA512 03783fc18d1dc17283ec540947907d98ecae2c6cb4350701d1976350aa39e1784d91e698fbb0d672d9be50c53ad9aa8e3d0e14ddc24d495654768709d8675826
diff --git a/x11-base/xorg-proto/xorg-proto-2024.1.ebuild b/x11-base/xorg-proto/xorg-proto-2024.1.ebuild
new file mode 100644
index 000000000000..980d24c44384
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2024.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.xz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/share/doc/{xorgproto,${P}} || die
+}
diff --git a/x11-base/xorg-proto/xorg-proto-9999.ebuild b/x11-base/xorg-proto/xorg-proto-9999.ebuild
index b353c2984da8..980d24c44384 100644
--- a/x11-base/xorg-proto/xorg-proto-9999.ebuild
+++ b/x11-base/xorg-proto/xorg-proto-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
MY_PN="${PN/xorg-/xorg}"
MY_P="${MY_PN}-${PV}"
@@ -17,9 +17,7 @@ inherit ${GIT_ECLASS} meson python-any-r1
DESCRIPTION="X.Org combined protocol headers"
HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
-else
+if [[ ${PV} != 9999* ]]; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.xz"
S="${WORKDIR}/${MY_P}"
@@ -37,7 +35,6 @@ BDEPEND="
')
)
"
-RDEPEND=""
python_check_deps() {
python_has_version "dev-python/libevdev[${PYTHON_USEDEP}]"