summaryrefslogtreecommitdiff
path: root/x11-base/xcb-proto/xcb-proto-1.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /x11-base/xcb-proto/xcb-proto-1.14.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'x11-base/xcb-proto/xcb-proto-1.14.ebuild')
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.14.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-base/xcb-proto/xcb-proto-1.14.ebuild b/x11-base/xcb-proto/xcb-proto-1.14.ebuild
new file mode 100644
index 000000000000..1d2fe92f1d17
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+XORG_MULTILIB=yes
+XORG_STATIC=no
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl emake -C xcbgen top_builddir="${BUILD_DIR}"
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl emake -C xcbgen top_builddir="${BUILD_DIR}"
+ python_foreach_impl python_optimize
+ fi
+}