summaryrefslogtreecommitdiff
path: root/x11-apps/xdriinfo/xdriinfo-1.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /x11-apps/xdriinfo/xdriinfo-1.0.6.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'x11-apps/xdriinfo/xdriinfo-1.0.6.ebuild')
-rw-r--r--x11-apps/xdriinfo/xdriinfo-1.0.6.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-apps/xdriinfo/xdriinfo-1.0.6.ebuild b/x11-apps/xdriinfo/xdriinfo-1.0.6.ebuild
new file mode 100644
index 000000000000..1801d61d66e8
--- /dev/null
+++ b/x11-apps/xdriinfo/xdriinfo-1.0.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit xorg-2 flag-o-matic multilib
+
+DESCRIPTION="query configuration information of DRI drivers"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ x11-proto/glproto"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ append-cppflags "-I${EPREFIX}/usr/$(get_libdir)/opengl/xorg-x11/include/"
+}