summaryrefslogtreecommitdiff
path: root/x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
commit0706fc6986773f4e4d391deff4ad5143c464ea4e (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild
parentaa3411e241a201d53a2689766fe419f2756819f3 (diff)
Revert "gentoo resync : 24.03.2019"
This reverts commit aa3411e241a201d53a2689766fe419f2756819f3.
Diffstat (limited to 'x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild')
-rw-r--r--x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild b/x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..2a83d1cb6f7e
--- /dev/null
+++ b/x11-apps/mkfontscale/mkfontscale-1.2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_EAUTORECONF="yes"
+inherit xorg-3
+
+DESCRIPTION="create an index of scalable font files for X"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEPEND="
+ x11-libs/libfontenc
+ media-libs/freetype:2
+ sys-libs/zlib
+ app-arch/bzip2"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-apps/mkfontdir-1.2.0"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Revert-Use-autoconf-instead-of-sed-to-substitute-bin.patch
+)
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-bzip2
+)