summaryrefslogtreecommitdiff
path: root/x11-apps/igt-gpu-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /x11-apps/igt-gpu-tools
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'x11-apps/igt-gpu-tools')
-rw-r--r--x11-apps/igt-gpu-tools/Manifest4
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild54
-rw-r--r--x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild54
-rw-r--r--x11-apps/igt-gpu-tools/metadata.xml14
4 files changed, 126 insertions, 0 deletions
diff --git a/x11-apps/igt-gpu-tools/Manifest b/x11-apps/igt-gpu-tools/Manifest
new file mode 100644
index 000000000000..af49c6b65fd4
--- /dev/null
+++ b/x11-apps/igt-gpu-tools/Manifest
@@ -0,0 +1,4 @@
+DIST igt-gpu-tools-1.23.tar.xz 1045716 BLAKE2B f5e55ce9b682f2a9f2c6ab73c1e8e933ebea09b343f3af02df50b5bdce3e2ac313b1f92709c6de0d9fc7ffe2e2c9dfa95d2918ae9bd561cc285cff30fe59c6fd SHA512 8697265a978359e28983f483bf95819844597fc2080923d15d0587f6d648081af27e8ea318873e20103bbf8446b9f1005c6bc90a6276d3169837abd181f96839
+EBUILD igt-gpu-tools-1.23.ebuild 1480 BLAKE2B 96daf039d3e8d00c898c34fccfbf55254b954273dded0106b4585510d9a0f724553b40d4c3f6649cb008b80bcaad1975af6121e2198742e7c0cca0ead61a4e80 SHA512 b636e28baa9ae33bc971273c3cb165da041f36aff7eb2cd329d6e62d8b24938d749282674e072fb7a32e2220db068dea89258ae9b2554669bfd02968b79a8b87
+EBUILD igt-gpu-tools-9999.ebuild 1480 BLAKE2B 96daf039d3e8d00c898c34fccfbf55254b954273dded0106b4585510d9a0f724553b40d4c3f6649cb008b80bcaad1975af6121e2198742e7c0cca0ead61a4e80 SHA512 b636e28baa9ae33bc971273c3cb165da041f36aff7eb2cd329d6e62d8b24938d749282674e072fb7a32e2220db068dea89258ae9b2554669bfd02968b79a8b87
+MISC metadata.xml 519 BLAKE2B 6763311f36b9997f2599a385dc7d0978874bab850ca0d06a3620c4767c31e0b35b9173e37ef606559919b2ebda095ac48b846107a8c9b18e87f942b465be91a6 SHA512 77a0a295e8c82570da621c4631d171dbf6564c00a6aee0e9e0261f5217317d19f5cdac134320f486c89e26c84a2f0c1a21d3b1d42b32676a0fe1d48fbc752569
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild
new file mode 100644
index 000000000000..65bdd0b60689
--- /dev/null
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.23.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGIT_REPO_URI="https://gitlab.freedesktop.org/drm/${PN}.git"
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Intel GPU userland tools"
+
+HOMEPAGE="https://01.org/linuxgraphics https://gitlab.freedesktop.org/drm/igt-gpu-tools"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.x.org/releases/individual/app/${P}.tar.xz"
+fi
+LICENSE="MIT"
+SLOT="0"
+IUSE="alsa chamelium doc glib gsl sound valgrind video_cards_amdgpu video_cards_intel video_cards_nouveau X xrandr xv"
+REQUIRED_USE="chamelium? ( glib gsl )"
+RESTRICT="test"
+
+X86_RDEPEND="
+ xv? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ )"
+X86_DEPEND="x11-base/xorg-proto
+ >=dev-util/peg-0.1.18"
+RDEPEND="sys-apps/kmod:=
+ sys-libs/libunwind:=
+ sys-process/procps:=
+ virtual/libudev:=
+ >=x11-libs/cairo-1.12.0[X?]
+ >=x11-libs/libdrm-2.4.82[video_cards_amdgpu?,video_cards_intel?,video_cards_nouveau?]
+ >=x11-libs/libpciaccess-0.10
+ alsa? ( media-libs/alsa-lib:= )
+ chamelium? ( dev-libs/xmlrpc-c )
+ glib? ( dev-libs/glib:2 )
+ gsl? ( sci-libs/gsl )
+ valgrind? ( dev-util/valgrind )
+ video_cards_intel? ( sys-libs/zlib:= )
+ xrandr? ( >=x11-libs/libXrandr-1.3 )
+ amd64? ( ${X86_RDEPEND} )
+ x86? ( ${X86_RDEPEND} )"
+DEPEND="${RDEPEND}
+ amd64? ( ${X86_DEPEND} )
+ x86? ( ${X86_DEPEND} )
+ doc? ( >=dev-util/gtk-doc-1.25-r1 )"
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
new file mode 100644
index 000000000000..65bdd0b60689
--- /dev/null
+++ b/x11-apps/igt-gpu-tools/igt-gpu-tools-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGIT_REPO_URI="https://gitlab.freedesktop.org/drm/${PN}.git"
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Intel GPU userland tools"
+
+HOMEPAGE="https://01.org/linuxgraphics https://gitlab.freedesktop.org/drm/igt-gpu-tools"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.x.org/releases/individual/app/${P}.tar.xz"
+fi
+LICENSE="MIT"
+SLOT="0"
+IUSE="alsa chamelium doc glib gsl sound valgrind video_cards_amdgpu video_cards_intel video_cards_nouveau X xrandr xv"
+REQUIRED_USE="chamelium? ( glib gsl )"
+RESTRICT="test"
+
+X86_RDEPEND="
+ xv? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv
+ )"
+X86_DEPEND="x11-base/xorg-proto
+ >=dev-util/peg-0.1.18"
+RDEPEND="sys-apps/kmod:=
+ sys-libs/libunwind:=
+ sys-process/procps:=
+ virtual/libudev:=
+ >=x11-libs/cairo-1.12.0[X?]
+ >=x11-libs/libdrm-2.4.82[video_cards_amdgpu?,video_cards_intel?,video_cards_nouveau?]
+ >=x11-libs/libpciaccess-0.10
+ alsa? ( media-libs/alsa-lib:= )
+ chamelium? ( dev-libs/xmlrpc-c )
+ glib? ( dev-libs/glib:2 )
+ gsl? ( sci-libs/gsl )
+ valgrind? ( dev-util/valgrind )
+ video_cards_intel? ( sys-libs/zlib:= )
+ xrandr? ( >=x11-libs/libXrandr-1.3 )
+ amd64? ( ${X86_RDEPEND} )
+ x86? ( ${X86_RDEPEND} )"
+DEPEND="${RDEPEND}
+ amd64? ( ${X86_DEPEND} )
+ x86? ( ${X86_DEPEND} )
+ doc? ( >=dev-util/gtk-doc-1.25-r1 )"
diff --git a/x11-apps/igt-gpu-tools/metadata.xml b/x11-apps/igt-gpu-tools/metadata.xml
new file mode 100644
index 000000000000..df5e45209705
--- /dev/null
+++ b/x11-apps/igt-gpu-tools/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+</maintainer>
+<use>
+ <flag name="chamelium">Enables support for building Chamelium tests</flag>
+ <flag name="glib">Support reading config files via glib helpers</flag>
+ <flag name="valgrind">Support valgrind annotations</flag>
+ <flag name="xrandr">Enable support for the X RandR extension</flag>
+</use>
+</pkgmetadata>