summaryrefslogtreecommitdiff
path: root/www-servers/tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /www-servers/tornado
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'www-servers/tornado')
-rw-r--r--www-servers/tornado/Manifest2
-rw-r--r--www-servers/tornado/tornado-6.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/www-servers/tornado/Manifest b/www-servers/tornado/Manifest
index 84ab9244bc67..c71fa3c0d5f1 100644
--- a/www-servers/tornado/Manifest
+++ b/www-servers/tornado/Manifest
@@ -1,3 +1,5 @@
DIST tornado-6.0.4.tar.gz 496204 BLAKE2B 6c092214d03baf5cf7615b780043e2fa40a4ed623b7ca59a2528cc3625ba904b21ef93c528278adedaf83e3b6e5a6311d867833dfe9826637e97918dee6fa334 SHA512 d29d69cf40f8b34fb2c55d81b6ecd9bc7c6fdf644eb4ff35452829510c0d5ec185da0a6067fec3e8afb2bedf9f5f08b06adb0ad53dcab04cb791a75abc304d6e
+DIST tornado-6.1.tar.gz 497359 BLAKE2B ed5981dec5cca962f907f97b7f906c1eef40d2b2b6d6cc16a21bd0a0a91ee58a60bea84b7ceeeff30b3462d707c56a5062c71d4ac8f25ca6a306ded6c6f072c5 SHA512 0ec1db1fad911182bda547c177a18b107b906cf66576443069e2b986cf041b3d4ebe08e5a168aa5cd3b56547f32f8b384bacaf74db89f582951d7b610b7494e8
EBUILD tornado-6.0.4.ebuild 1377 BLAKE2B 8b418d14a03da19b2330ef40a109d2792dc6522c45b76323d554afe1f2b99a263dd82415ae3160b94597e3d7f1e6ee7ad083d728b6002751ec60faa3769d90c4 SHA512 a3b8b6b66516f842573c246eb94d394e790665ebf44e80525ff8b44ae4dc971857f24e78ed327d804ed916da597cf9973aa69540f4e1230d99f122d48564e2a0
+EBUILD tornado-6.1.ebuild 1134 BLAKE2B 467776656c9ff4d90337346ec3fffe4ea6e262bb89c269e447cf712dd4b828171ca5d64977a51880a81131b42ad039e6848f4da6d2d00f39d30ca1591f710ab5 SHA512 45fc144e6361e2237b6866f9d31535c814869bcb1746e722604048e7a4849c05c79041317f137286a5c58a2c551e8968e0cb3fbc506f056cd83a176a77de6f36
MISC metadata.xml 380 BLAKE2B 16a28ca707ba911df09dfad39b269bd888734c1f5e54fdc57d84f62b541e284f248137a01c13055f5e9fa1e1da0a2c9e1382006119cc11ec19302516262b7dc1 SHA512 e790429d61042b60a9011710e96df0044c64cc5ac941ab6268386138d3a66e46d40ed1098ec8bc164d9f4341040946ec7231e8f28dda11790ecc482b06978771
diff --git a/www-servers/tornado/tornado-6.1.ebuild b/www-servers/tornado/tornado-6.1.ebuild
new file mode 100644
index 000000000000..23fd9623ccf9
--- /dev/null
+++ b/www-servers/tornado/tornado-6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="https://www.tornadoweb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinxcontrib-asyncio
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ cd "${BUILD_DIR}/lib" || die
+ "${PYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}