summaryrefslogtreecommitdiff
path: root/www-servers/pshs/pshs-0.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /www-servers/pshs/pshs-0.4.1.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'www-servers/pshs/pshs-0.4.1.ebuild')
-rw-r--r--www-servers/pshs/pshs-0.4.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-servers/pshs/pshs-0.4.1.ebuild b/www-servers/pshs/pshs-0.4.1.ebuild
new file mode 100644
index 000000000000..e20baa15b0c6
--- /dev/null
+++ b/www-servers/pshs/pshs-0.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://github.com/mgorny/pshs/"
+SRC_URI="
+ https://github.com/mgorny/pshs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +magic qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature magic libmagic)
+ $(meson_feature qrcode qrencode)
+ $(meson_feature ssl)
+ $(meson_feature upnp)
+ )
+
+ meson_src_configure
+}