summaryrefslogtreecommitdiff
path: root/www-servers/h2o/h2o-2.2.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /www-servers/h2o/h2o-2.2.6-r1.ebuild
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'www-servers/h2o/h2o-2.2.6-r1.ebuild')
-rw-r--r--www-servers/h2o/h2o-2.2.6-r1.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/www-servers/h2o/h2o-2.2.6-r1.ebuild b/www-servers/h2o/h2o-2.2.6-r1.ebuild
index 3c0c14adba6b..2fdec9f496f3 100644
--- a/www-servers/h2o/h2o-2.2.6-r1.ebuild
+++ b/www-servers/h2o/h2o-2.2.6-r1.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
+EAPI="8"
CMAKE_MAKEFILE_GENERATOR="emake"
SSL_DEPS_SKIP=1
-USE_RUBY="ruby24 ruby25 ruby26"
+USE_RUBY="ruby26 ruby27"
inherit cmake ruby-single ssl-cert systemd toolchain-funcs
@@ -18,28 +17,26 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="libh2o +mruby"
-RDEPEND="
- acct-group/h2o
+RDEPEND="acct-group/h2o
acct-user/h2o
dev-lang/perl
+ !sci-libs/libh2o
sys-libs/zlib
libh2o? ( dev-libs/libuv )
- dev-libs/openssl:0=
-"
-DEPEND="
- ${RDEPEND}
- libh2o? ( virtual/pkgconfig )
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
mruby? (
${RUBY_DEPS}
|| (
dev-libs/onigmo
dev-libs/oniguruma
)
+ )"
+BDEPEND="libh2o? ( virtual/pkgconfig )
+ mruby? (
sys-devel/bison
virtual/pkgconfig
- )
-"
-RDEPEND+="!sci-libs/libh2o"
+ )"
PATCHES=( "${FILESDIR}"/${PN}-2.2-mruby.patch )