summaryrefslogtreecommitdiff
path: root/www-plugins/pdfjs/pdfjs-3.9.179.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-02 04:49:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-02 04:49:19 +0100
commit567324b6954816e085ab34edc30e531d26aed9f0 (patch)
tree80adbce807b40feae7fb1c5eb8ad5f94aa6f218e /www-plugins/pdfjs/pdfjs-3.9.179.ebuild
parent7a7daa06a06110abc743b5ebd9da85620a5679b4 (diff)
gentoo auto-resync : 02:08:2023 - 04:49:19
Diffstat (limited to 'www-plugins/pdfjs/pdfjs-3.9.179.ebuild')
-rw-r--r--www-plugins/pdfjs/pdfjs-3.9.179.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/www-plugins/pdfjs/pdfjs-3.9.179.ebuild b/www-plugins/pdfjs/pdfjs-3.9.179.ebuild
new file mode 100644
index 000000000000..7d2127ad585d
--- /dev/null
+++ b/www-plugins/pdfjs/pdfjs-3.9.179.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A PDF reader in JavaScript"
+HOMEPAGE="https://mozilla.github.io/pdf.js/"
+SRC_URI="https://github.com/mozilla/pdf.js/releases/download/v${PV}/${P}-dist.zip -> ${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ insinto /usr/share/pdf.js/
+
+ doins -r build
+ doins -r web
+}