summaryrefslogtreecommitdiff
path: root/www-plugins/passff/passff-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /www-plugins/passff/passff-1.3.ebuild
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'www-plugins/passff/passff-1.3.ebuild')
-rw-r--r--www-plugins/passff/passff-1.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-plugins/passff/passff-1.3.ebuild b/www-plugins/passff/passff-1.3.ebuild
new file mode 100644
index 000000000000..2cc136021db6
--- /dev/null
+++ b/www-plugins/passff/passff-1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mozextension
+
+DESCRIPTION="zx2c4 pass manager extension for Firefox"
+HOMEPAGE="https://github.com/passff/passff"
+SRC_URI="https://addons.mozilla.org/firefox/downloads/file/914592/passff-1.3-an+fx-linux.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="firefox firefox-bin"
+
+RDEPEND="www-plugins/passff-host[firefox]"
+REQUIRED_USE="|| ( firefox firefox-bin )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ xpi_unpack "passff-1.3-an+fx-linux.xpi"
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME
+ if use firefox; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
+ xpi_install "passff-1.3-an+fx-linux"
+ fi
+
+ if use firefox-bin; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "passff-1.3-an+fx-linux"
+ fi
+}