summaryrefslogtreecommitdiff
path: root/www-plugins/gosuslugi-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /www-plugins/gosuslugi-plugin
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'www-plugins/gosuslugi-plugin')
-rw-r--r--www-plugins/gosuslugi-plugin/Manifest5
-rw-r--r--www-plugins/gosuslugi-plugin/gosuslugi-plugin-3.1.1.0.ebuild58
-rw-r--r--www-plugins/gosuslugi-plugin/metadata.xml11
3 files changed, 74 insertions, 0 deletions
diff --git a/www-plugins/gosuslugi-plugin/Manifest b/www-plugins/gosuslugi-plugin/Manifest
new file mode 100644
index 000000000000..75fbb1c90670
--- /dev/null
+++ b/www-plugins/gosuslugi-plugin/Manifest
@@ -0,0 +1,5 @@
+DIST gosuslugi-plugin-3.1.1.0_amd64.deb 5264616 BLAKE2B 0aadd08a26ae70e9a73611de3faccceb8bb53f8f36df34398d72f2a3d34ad5d0efa6a9bc0b05daf6b4a1fe7e2a498506df7a8bc094eae002ae7e7f532b24f98f SHA512 7152b08b22d93dee63aaed61012ed53f07a52beee113a0fbd639a435d57f251885947c2e874fb1e799f5db36340093024641f504f95d5ef788bfc30c4e9030aa
+DIST gosuslugi-plugin-3.1.1.0_mac.pkg 9712969 BLAKE2B f9234cb5283f27e680d448f6c4edf298495451c4b1af6bb6cdf5cf9e016877ce587a9dbfa9f78631d28f9d9fb1bb5d1aa505ecd947549bf0818e2662be6197c8 SHA512 e22530e72ce769fdee10fc63e140d7b294a3a9067e3ae113de1267745c16f0eb1c526f2a9f9d693263de92230c0e132362e3ed6c8653903addff47920f5632e0
+DIST gosuslugi-plugin-3.1.1.0_x86.deb 5198728 BLAKE2B 68bcd5745e14a13fe13cc0dbcf3c66c6471a405a5a6957f112b843fa935cefc27fd60effdffba86593175deed1eb66a091558c2766b3fb5a2f7b8c860e61ee09 SHA512 2a49778f94421b5827d52725a72745482eaafb825dbadb2696a1bccbcf491a775ff1b1eefebba565906c7c7bce8d7106003999a1e0dc69e69781e5a639597223
+EBUILD gosuslugi-plugin-3.1.1.0.ebuild 1596 BLAKE2B 0516cc550db19526c8b3f8695665f5ea7af6a4f17506cf705ef6412e0a97efd7e0d0771c8ef41b2ec85c28e3263679ca63a6aba00b7c2ffd4c8c32e5c3836f14 SHA512 5375aa2c7f3b09ba4ddb17665b829003c83518797338dec66be962545653b3116ef92e0ad45752bf5517b74e50b3d203c949a785aa61e2f1f8cb0a9f14f08347
+MISC metadata.xml 419 BLAKE2B a0d7c2098f48e9babb8d1922e955cde986abe24a2b6c62209c27def20ddaa05c745fce0dbe5c9bf2a00cfa8065bdadf9bab2b274b990237befdbcb730d671fc9 SHA512 ff3a126f33bc4047028503cc766dbc569ee33e85d57ead56ebbaf8c87d9074008c9f80d75b2ef655aa160e878284cf68385b2f047ec5025cf9cdf666163c0c09
diff --git a/www-plugins/gosuslugi-plugin/gosuslugi-plugin-3.1.1.0.ebuild b/www-plugins/gosuslugi-plugin/gosuslugi-plugin-3.1.1.0.ebuild
new file mode 100644
index 000000000000..c3b258570dc3
--- /dev/null
+++ b/www-plugins/gosuslugi-plugin/gosuslugi-plugin-3.1.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils unpacker
+
+DESCRIPTION="Crypto-provider browser plugin for russian e-gov site https://gosuslugi.ru/"
+
+SRC_URI="
+ amd64? ( https://ds-plugin.gosuslugi.ru/plugin/upload/assets/distrib/IFCPlugin-x86_64.deb -> ${P}_amd64.deb )
+ x86? ( https://ds-plugin.gosuslugi.ru/plugin/upload/assets/distrib/IFCPlugin-i386.deb -> ${P}_x86.deb )
+ x64-macos? ( https://ds-plugin.gosuslugi.ru/plugin/upload/assets/distrib/IFCPlugin.pkg -> ${P}_mac.pkg )
+"
+# x86-macos? ( https://ds-plugin.gosuslugi.ru/plugin/upload/assets/distrib/IFCPlugin.pkg -> ${P}_mac.pkg )
+# x86-winnt? ( https://ds-plugin.gosuslugi.ru/plugin/htdocs/plugin/IFCPlugin.msi )
+# x64-winnt? ( https://ds-plugin.gosuslugi.ru/plugin/htdocs/plugin/IFCPlugin-x64.msi )
+
+HOMEPAGE="http://gosuslugi.ru/"
+LICENSE="EULA"
+RESTRICT="mirror"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 x64-macos x86-macos"
+IUSE="multilib"
+
+REQUIRED_USE="amd64? ( multilib )"
+
+# TODO: minimal useflag (I can't do it now, since
+# it seems like I brake my token and it is uninitialized now)
+RDEPEND="
+ dev-libs/libxml2:2
+ sys-apps/pcsc-lite:0
+ virtual/libusb:0
+"
+DEPEND="${RDEPEND}"
+
+QA_PREBUILT="*"
+QA_SONAME_NO_SYMLINK="usr/lib32/.* usr/lib64/.*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_deb ${A}
+ rm usr/lib/mozilla/plugins/lib/libcapi_engine_linux.so
+}
+
+src_install() {
+ insinto /
+ doins -r usr etc opt
+ dobin usr/bin/ifc_chrome_host
+ keepdir /var/log/ifc
+ fperms 777 /var/log/ifc
+}
+
+pkg_postinst() {
+ cd /etc/update_ccid_boundle
+ sh ./update_ccid_boundle.sh
+}
diff --git a/www-plugins/gosuslugi-plugin/metadata.xml b/www-plugins/gosuslugi-plugin/metadata.xml
new file mode 100644
index 000000000000..7579a29b5ee1
--- /dev/null
+++ b/www-plugins/gosuslugi-plugin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mva@gentoo.org</email>
+ <description>Also, you can find me on IRC (FreeNode) as mva, or in Telegram as @mva_name</description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+ </maintainer>
+ <longdescription>FIXME</longdescription>
+ <use/>
+</pkgmetadata> \ No newline at end of file