summaryrefslogtreecommitdiff
path: root/www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.18_beta.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-03 08:13:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-03 08:13:59 +0100
commit2df2e0ebc717aa53904c920c1a361423dfc3a5f7 (patch)
treed81b257b3923100dc55a999dd12b2198a6d35b99 /www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.18_beta.ebuild
parent75abd8d3830449158bdd27f9c4701bcbadc55080 (diff)
gentoo auto-resync : 03:04:2024 - 08:13:58
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.18_beta.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.18_beta.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.18_beta.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.18_beta.ebuild
new file mode 100644
index 000000000000..8002828065ef
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-124.0.6367.18_beta.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2012-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+KEYWORDS="-* ~amd64"
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="google-chrome"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ sys-libs/glibc
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/chromium-browser"
+ doins -r WidevineCdm
+}