summaryrefslogtreecommitdiff
path: root/www-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
commit7d040c2d1b0c38c8635ec28dfaa632a2db8be895 (patch)
tree78e9474cad949bcd1254749d61f4f6b9e7d488bf /www-misc
parent0d39cf7bd8aae36b5d8eb4272a42dc6919216e34 (diff)
gentoo auto-resync : 11:04:2023 - 23:39:54
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/Manifest.gzbin2920 -> 2924 bytes
-rw-r--r--www-misc/urlwatch/Manifest2
-rw-r--r--www-misc/urlwatch/urlwatch-2.26.ebuild75
3 files changed, 77 insertions, 0 deletions
diff --git a/www-misc/Manifest.gz b/www-misc/Manifest.gz
index 5b0d9f92080c..d9ddd3bf5620 100644
--- a/www-misc/Manifest.gz
+++ b/www-misc/Manifest.gz
Binary files differ
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index 4feaf82246bb..d513a70a976b 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,5 +1,7 @@
DIST urlwatch-2.24.tar.gz 141175 BLAKE2B 7868ba757493c97ef65136d3da67ef3bb6b0d62e52ab150e169d66adea420872990527a622d305bd14923ff367041d615dcea1495871258040ec2cbb73ee7613 SHA512 ed84cb69ecd8894851c3be0165edfa1dfee92a0b49ea1383e4cfd7c31eb0604f99b1a90d9508753064b58bdd8fc4c0369d817303858d07562b37c3f2ac4cae52
DIST urlwatch-2.25.tar.gz 168241 BLAKE2B 85f76e849495f5457f43ccd37035aae84c6ae4c8649005e617a6a585bf3b73d30914f8c7a89c0fb9bb04cc07a8797d77be07807e8d7c64976355749417b39e40 SHA512 af14c5b4e11345e56e6f326c114629f1e074215d6cc66d9c642424b2a689dc80339157f1b2547fdbe7b7a13d520e2b83bf23c7477da4ae4e43d108e6452624ca
+DIST urlwatch-2.26.tar.gz 174305 BLAKE2B c7990b0ecca8bb18632ba717dabfed3e3cdf147ff463e1221c4f7002fcb862d162421ac927bd6a570369a1833268cc08668e284e425e954a4eea8d41cb30eafd SHA512 df214e3576dcbc8f18338a17f890e53ce9142fb98ea5042567eb415e697ee1a19d40b00404a40c0cc4aaaaa35ff3d838d9e0273a6bfe5178059560723ef6e4ca
EBUILD urlwatch-2.24.ebuild 2436 BLAKE2B 39a408c3db13371bb4b4839ac8cd3c31f38a6b0da6d4c5d9a0e1e021eb4bf1bf610495763a7afa1c623378f35387798f5603d0954431857be2b096724ff0fbc5 SHA512 6514fe12bb3929ae65350c35ca3efe00119f91129a274e333a4876ce3a3ca3ef818658321c7bb5b0e41a940e4a785b7d055e14c9e301e707069282a7917217ea
EBUILD urlwatch-2.25.ebuild 2486 BLAKE2B cdb7233bd1a743a52d9a8e402be707eef53ffc44ac29e0c9b5885d2b7110638b09e3ed87aa9ce7b97e1c74c2c9b48a82109f94b1a8075826f7124aceca32de75 SHA512 9528fcd2c41ba47b1b27c7371fa8bea2ba99b6723d4966a60273515d0fb7bf47ee1eb215303b72306ceb656e4d1faa5456e5b1bbc5044d1a1a0257d27d2ef29a
+EBUILD urlwatch-2.26.ebuild 2143 BLAKE2B 9a1492e57fa0e0d081ec14fabebc99f99b424c28a6543bc3dbdabc8aa1e4f00d4f82c304a6b9aeb8a5d64dcdfdc31e19aa85adab779262d9e1e5a0ed204446ff SHA512 ed7e278baa982387b99a711ef4f3c86787afc77e8b4b59c76d0bffe259d3b926a956627e4d19213aa4644297899093225cc7959fcb437e5cb0b1ec0a7542f104
MISC metadata.xml 541 BLAKE2B f4518dac79cafa9a225d87e125b1fbb3e090c7d3ea1d90a307d8b881379b809112fdc0bd3da6a229daf228aa5660fd130a048fefc63c9a19743987a4c94e528d SHA512 86cf47f19a24fb11c4b1a02b1fe9490a5c171c77b4237a1d0557ce553b1b97ef05f1849f4d745aa0c86f27b2c74f646898f94484ecf75848379b3a02f4157170
diff --git a/www-misc/urlwatch/urlwatch-2.26.ebuild b/www-misc/urlwatch/urlwatch-2.26.ebuild
new file mode 100644
index 000000000000..84e863172064
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.26.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="
+ https://thp.io/2008/urlwatch/
+ https://github.com/thp/urlwatch/
+ https://pypi.org/project/urlwatch/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/minidb-2.0.6[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jq[${PYTHON_USEDEP}]
+ dev-python/pytesseract[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/alabaster
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Require the pdftotext module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test.pdf]"
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test-password.pdf]"
+ # Skip code quality check
+ "lib/urlwatch/tests/test_handler.py::test_pep8_conformance"
+)
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/jq; then
+ elog "Install 'dev-python/jq' to enable jq filtering support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ if ! has_version dev-python/pytesseract; then
+ elog "Install 'dev-python/pytesseract' to enable OCR support"
+ fi
+ elog "HTML parsing can be improved by installing one of the following packages"
+ elog "and changing the html2text subfilter parameter:"
+ elog "dev-python/beautifulsoup4"
+ elog "app-text/html2text"
+ elog "dev-python/html2text"
+ elog "www-client/lynx"
+ fi
+}