summaryrefslogtreecommitdiff
path: root/www-misc/profile-sync-daemon/profile-sync-daemon-6.35.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /www-misc/profile-sync-daemon/profile-sync-daemon-6.35.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'www-misc/profile-sync-daemon/profile-sync-daemon-6.35.ebuild')
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-6.35.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-6.35.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-6.35.ebuild
new file mode 100644
index 000000000000..844169f700ae
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-6.35.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+
+SRC_URI="https://github.com/graysky2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync[xattr]
+ sys-apps/systemd"
+
+src_install() {
+ emake DESTDIR="${D}" COMPRESS_MAN=0 install
+}
+
+pkg_postinst() {
+ local replacing
+ for replacing in ${REPLACING_VERSIONS}; do
+ if [[ "$(ver_cut 1 "${replacing}")" == "5" ]]; then
+ ewarn "${PN}-6 and later dropped OpenRC and /etc/psd.conf support"
+ ewarn "See https://github.com/graysky2/profile-sync-daemon#note-for-version-6"
+ break
+ fi
+ done
+}