summaryrefslogtreecommitdiff
path: root/www-misc/htdig/files/htdig-3.2.0_beta6-musl.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-misc/htdig/files/htdig-3.2.0_beta6-musl.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'www-misc/htdig/files/htdig-3.2.0_beta6-musl.patch')
-rw-r--r--www-misc/htdig/files/htdig-3.2.0_beta6-musl.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-misc/htdig/files/htdig-3.2.0_beta6-musl.patch b/www-misc/htdig/files/htdig-3.2.0_beta6-musl.patch
new file mode 100644
index 000000000000..5b405993a792
--- /dev/null
+++ b/www-misc/htdig/files/htdig-3.2.0_beta6-musl.patch
@@ -0,0 +1,33 @@
+--- a/configure.in
++++ b/configure.in
+@@ -176,7 +176,7 @@
+ AC_FUNC_STRFTIME
+ AC_FUNC_STRPTIME
+ AC_FUNC_VPRINTF
+-AC_CHECK_FUNCS([alarm btowc bzero ftime getcwd gettimeofday localtime_r memcmp memcpy memmove memset mkstemp munmap pstat_getdynamic raise re_comp regcomp select setlocale strchr strcspn strdup strerror strrchr strstr strtol strtoul timegm])
++AC_CHECK_FUNCS([alarm btowc bzero ftime getcwd gettimeofday localtime_r memcmp memcpy memmove memset mkstemp munmap pstat_getdynamic raise re_comp regcomp rresvport select setlocale strchr strcspn strdup strerror strrchr strstr strtol strtoul timegm])
+ AC_REPLACE_FUNCS(snprintf vsnprintf)
+
+ # More header checks--here use C++
+diff -ur a/htdig-3.2.0b6/htnet/Connection.cc b/htdig-3.2.0b6/htnet/Connection.cc
+--- a/htnet/Connection.cc
++++ b/htnet/Connection.cc
+@@ -64,7 +64,7 @@
+
+ typedef void (*SIGNAL_HANDLER) (...);
+
+-#ifndef _MSC_VER /* _WIN32 */
++#ifdef HAVE_RRESVPORT
+ extern "C" {
+ int rresvport(int *);
+ }
+@@ -161,8 +161,7 @@
+ {
+ int aport = IPPORT_RESERVED - 1;
+
+-// Native Windows (MSVC) has no rresvport
+-#ifndef _MSC_VER /* _WIN32 */
++#ifdef HAVE_RRESVPORT
+ sock = rresvport(&aport);
+ #else
+ return NOTOK;