summaryrefslogtreecommitdiff
path: root/www-client/tangram/tangram-3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-29 23:15:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-29 23:15:57 +0100
commit2ebceb686e2370a0a9172a7be4a3c29555a08b80 (patch)
treeda445d4418a55d8e05bfb6d709fb65ac3eca9daa /www-client/tangram/tangram-3.0.ebuild
parente169149b84bc9ff33d3286d60dfab754d2e0e4be (diff)
gentoo auto-resync : 29:04:2023 - 23:15:57
Diffstat (limited to 'www-client/tangram/tangram-3.0.ebuild')
-rw-r--r--www-client/tangram/tangram-3.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/www-client/tangram/tangram-3.0.ebuild b/www-client/tangram/tangram-3.0.ebuild
new file mode 100644
index 000000000000..bb7361b4cb58
--- /dev/null
+++ b/www-client/tangram/tangram-3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+DESCRIPTION="Web browser designed to organize and run Web applications"
+HOMEPAGE="https://apps.gnome.org/app/re.sonny.Tangram/
+ https://github.com/sonnyp/Tangram/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sonnyp/${PN^}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/gjs-1.76.0
+ gui-libs/gtk:4
+ gui-libs/libadwaita:1
+ net-libs/webkit-gtk:6
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/blueprint-compiler
+ dev-util/desktop-file-utils
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0-dont-validate-appstream.patch )
+
+DOCS=( README.md TODO.md )
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}