summaryrefslogtreecommitdiff
path: root/www-client/surf/surf-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-client/surf/surf-2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-client/surf/surf-2.0.ebuild')
-rw-r--r--www-client/surf/surf-2.0.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/www-client/surf/surf-2.0.ebuild b/www-client/surf/surf-2.0.ebuild
new file mode 100644
index 000000000000..33d0ddd78c8a
--- /dev/null
+++ b/www-client/surf/surf-2.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="https://surf.suckless.org/"
+SRC_URI="
+ https://dl.suckless.org/${PN}/${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ net-libs/libsoup
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ x11-libs/libX11
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="
+ !sci-chemistry/surf
+ ${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-misc/dmenu
+ !savedconfig? (
+ net-misc/curl
+ x11-terms/st
+ )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-gentoo.patch
+)
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ default
+
+ restore_config config.h
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 0.4.1-r1 ]]; then
+ ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
+ ewarn "and its contents to no longer be world readable (see bug #404983)"
+ fi
+}