summaryrefslogtreecommitdiff
path: root/www-client/qutebrowser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /www-client/qutebrowser
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'www-client/qutebrowser')
-rw-r--r--www-client/qutebrowser/Manifest2
-rw-r--r--www-client/qutebrowser/qutebrowser-2.5.0.ebuild122
2 files changed, 124 insertions, 0 deletions
diff --git a/www-client/qutebrowser/Manifest b/www-client/qutebrowser/Manifest
index 5f14617d0f55..bfcc365ebb22 100644
--- a/www-client/qutebrowser/Manifest
+++ b/www-client/qutebrowser/Manifest
@@ -1,4 +1,6 @@
DIST qutebrowser-2.4.0.tar.gz 6074001 BLAKE2B 9eda4a72b9050d6992681803b69778d954654fffd78aa524dfba9bddcbb8e54bd84e6725c30d826dddeb45b6b76e06d7401c7ad22d15a153b4cc1104e791cc84 SHA512 e4341a57a259a31e1c665eec34329594bb3d8390e3c612a15c1857ff12cb9e1f5b30954dd0cd91bee0a40ec0d97c59349ab7cd699626434a89c7d40e5dd961f7
+DIST qutebrowser-2.5.0.tar.gz 6086105 BLAKE2B c95afbbdfeebe4352e461cef78d499e9efa9de2e4acc2cedf350904bd617a4f238c34042369655030e53433f941288ff676f8ffd873683939ddd38ff01604aa1 SHA512 41ab6f6d2b72c94e0f66ba0a80999d820748d0f86dbec92583a2be88725f1ebd7517dd75edbaa0ce60bc029ed4dc0dd3e30a1cb25ab4ef940b968c87b4df2472
EBUILD qutebrowser-2.4.0.ebuild 4370 BLAKE2B 9554c0148141525d54f4a2ca3a262f93a53fe6162174903b07f03d29e1e91788eddfe8c638f97c9855a0719291267b4fae9c3531f67873329e83907f8f1f0e68 SHA512 9bd7e90cd9869a3385e47d0b0bc594578300f9bffc7683bba318a07382dacf0103420aee5bcc72d504b3bfa3cb7c16f65ecc43901b4efe5dafaada153071e2d0
+EBUILD qutebrowser-2.5.0.ebuild 4292 BLAKE2B 09180bced9a89d811b35965996167a9ec1ca6df0b72d4c3bd16eac06d669efda7ea6570b5ba85a6eb7ffe6c8b5b82932f3fd417ced58be70d0f26293733a312d SHA512 3bc9e3e877285d80c870e88632a47202ea909aaae525d693c2ce40c82b57c1e83ad2447620e71ebd97d4fb49bd6ed0f23200dc11e2965738084336039ef63ac4
EBUILD qutebrowser-9999.ebuild 4292 BLAKE2B 09180bced9a89d811b35965996167a9ec1ca6df0b72d4c3bd16eac06d669efda7ea6570b5ba85a6eb7ffe6c8b5b82932f3fd417ced58be70d0f26293733a312d SHA512 3bc9e3e877285d80c870e88632a47202ea909aaae525d693c2ce40c82b57c1e83ad2447620e71ebd97d4fb49bd6ed0f23200dc11e2965738084336039ef63ac4
MISC metadata.xml 945 BLAKE2B e796d777d56a5452b6652d77e011dfb160684f6e7498d0c4fad583bb828ecd111c25be5d80ed906b9b579e6ccd33315fc20a727342df0fb1b66b1a71effcea25 SHA512 80a65a391a84208042d9e7a6e0b5e8644ed07d5e389cd6a7b314b961dca5cff6406c5556693b34dcd275acfb27d05d9e40f77e9d503f9e3e8054ab6b6763932d
diff --git a/www-client/qutebrowser/qutebrowser-2.5.0.ebuild b/www-client/qutebrowser/qutebrowser-2.5.0.ebuild
new file mode 100644
index 000000000000..6e52913c8194
--- /dev/null
+++ b/www-client/qutebrowser/qutebrowser-2.5.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/qutebrowser/qutebrowser.git"
+else
+ SRC_URI="https://github.com/qutebrowser/qutebrowser/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
+HOMEPAGE="https://www.qutebrowser.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+adblock widevine"
+
+RDEPEND="
+ dev-qt/qtcore:5[icu]
+ dev-qt/qtgui:5[png]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
+ $(python_gen_cond_dep '
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},dbus,declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP},libyaml(+)]
+ dev-python/zipp[${PYTHON_USEDEP}]
+ adblock? ( dev-python/adblock[${PYTHON_USEDEP}] )')
+ widevine? ( www-plugins/chrome-binary-plugins )"
+BDEPEND="
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-bdd[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xvfb[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ )')"
+[[ ${PV} != 9999 ]] || BDEPEND+=" app-text/asciidoc"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ if use widevine; then
+ local widevine=${EPREFIX}/usr/$(get_libdir)/chromium-browser/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so
+ sed "/yield from _qtwebengine_settings_args/a\ yield '--widevine-path=${widevine}'" \
+ -i ${PN}/config/qtargs.py || die
+ fi
+
+ # let eclass handle python
+ sed -i '/setup.py/d' misc/Makefile || die
+
+ [[ ${PV} != 9999 ]] || ${EPYTHON} scripts/asciidoc2html.py || die
+
+ # these plugins/tests are unnecessary here and have extra dependencies
+ sed -e '/pytest-benchmark/d;s/--benchmark[^ ]*//' \
+ -e '/pytest-instafail/d;s/--instafail//' \
+ -i pytest.ini || die
+ [[ ${PV} == 9999 ]] || rm tests/unit/scripts/test_problemmatchers.py || die
+ [[ ${PV} != 9999 ]] || rm tests/unit/scripts/test_run_vulture.py || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # end2end and other IPC tests are broken with "Name error" if
+ # socket path is over 104 characters (=124 in /var/tmp/portage)
+ # https://github.com/qutebrowser/qutebrowser/issues/888 (not just OSX)
+ tests/end2end
+ tests/unit/misc/test_ipc.py
+ # tests that don't know about our newer qtwebengine
+ tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
+ tests/unit/utils/test_version.py::TestChromiumVersion
+ # may misbehave depending on installed old python versions
+ tests/unit/misc/test_checkpyver.py::test_old_python
+ # bug 819393
+ tests/unit/commands/test_userscripts.py::test_custom_env[_POSIXUserscriptRunner]
+ )
+ use widevine && EPYTEST_DESELECT+=( tests/unit/config/test_qtargs.py )
+
+ # skip benchmarks (incl. _tree), and warning tests broken by -Wdefault
+ epytest -k 'not _bench and not _matches_tree and not _warning'
+}
+
+python_install_all() {
+ emake -f misc/Makefile DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ rm "${ED}"/usr/share/${PN}/scripts/{mkvenv,utils}.py || die
+ fperms -x /usr/share/${PN}/{scripts/cycle-inputs.js,userscripts/README.md}
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "PDF display support" www-plugins/pdfjs
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that optional scripts in ${EROOT}/usr/share/${PN}/{user,}scripts"
+ elog "have additional dependencies not covered by this ebuild, for example"
+ elog "view_in_mpv needs media-video/mpv[lua] and net-misc/yt-dlp."
+ fi
+}