summaryrefslogtreecommitdiff
path: root/www-client/qutebrowser/qutebrowser-2.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 09:13:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 09:13:50 +0000
commit0bb8253b38dc8638a46b66ba909c1bfd1054e1ef (patch)
treed408176c81eb4f81d8b3e95a66abc8eedec620e4 /www-client/qutebrowser/qutebrowser-2.5.2.ebuild
parent1f709ed82b8014b4c156f87c66cee7d0d1d3905d (diff)
gentoo auto-resync : 04:11:2022 - 09:13:50
Diffstat (limited to 'www-client/qutebrowser/qutebrowser-2.5.2.ebuild')
-rw-r--r--www-client/qutebrowser/qutebrowser-2.5.2.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/www-client/qutebrowser/qutebrowser-2.5.2.ebuild b/www-client/qutebrowser/qutebrowser-2.5.2.ebuild
index b531a2983052..d3151e4cf8de 100644
--- a/www-client/qutebrowser/qutebrowser-2.5.2.ebuild
+++ b/www-client/qutebrowser/qutebrowser-2.5.2.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1 optfeature xdg
+inherit distutils-r1 xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -21,7 +21,7 @@ HOMEPAGE="https://www.qutebrowser.org/"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="+adblock widevine"
+IUSE="+adblock pdf widevine"
RDEPEND="
dev-qt/qtcore:5[icu]
@@ -37,6 +37,7 @@ RDEPEND="
dev-python/pyyaml[${PYTHON_USEDEP},libyaml(+)]
dev-python/zipp[${PYTHON_USEDEP}]
adblock? ( dev-python/adblock[${PYTHON_USEDEP}] )')
+ pdf? ( <www-plugins/pdfjs-3 )
widevine? ( www-plugins/chrome-binary-plugins )"
BDEPEND="
$(python_gen_cond_dep '
@@ -59,6 +60,11 @@ distutils_enable_tests pytest
src_prepare() {
distutils-r1_src_prepare
+ if use pdf; then
+ sed '/^content.pdfjs:/,+1s/false/true/' \
+ -i ${PN}/config/configdata.yml || die
+ fi
+
if use widevine; then
local widevine=${EPREFIX}/usr/$(get_libdir)/chromium-browser/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so
sed "/yield from _qtwebengine_settings_args/a\ yield '--widevine-path=${widevine}'" \
@@ -116,8 +122,6 @@ python_install_all() {
pkg_postinst() {
xdg_pkg_postinst
- optfeature "PDF display support" www-plugins/pdfjs
-
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "Note that optional scripts in ${EROOT}/usr/share/${PN}/{user,}scripts"
elog "have additional dependencies not covered by this ebuild, for example"