summaryrefslogtreecommitdiff
path: root/www-client/pybugz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
commit31c69c39a3648b52dd931a40b198714249e8a5ec (patch)
treec7bfb4db01cf185b6b8f7bde72d9cc5d14d8db22 /www-client/pybugz
parentdce60e5aa0a12ccc07c10a0a2c3f8f063393b32a (diff)
gentoo auto-resync : 15:02:2024 - 23:36:26
Diffstat (limited to 'www-client/pybugz')
-rw-r--r--www-client/pybugz/Manifest3
-rw-r--r--www-client/pybugz/pybugz-0.13-r3.ebuild32
-rw-r--r--www-client/pybugz/pybugz-9999.ebuild10
3 files changed, 38 insertions, 7 deletions
diff --git a/www-client/pybugz/Manifest b/www-client/pybugz/Manifest
index 7140610ff6a9..6ee0d14244e6 100644
--- a/www-client/pybugz/Manifest
+++ b/www-client/pybugz/Manifest
@@ -1,4 +1,5 @@
DIST pybugz-0.13.tar.gz 26876 BLAKE2B fbab5ff308e137bf590620362fe102408444c7c1cb375f2c2d426cf5873fba5cf8759d7083be4c6bd305191680af8d1afc3aaf0648e186a93af4dd0b60442093 SHA512 2cbbd32b44d0d513e91e5c35dca5c68e34a963190c31f9139922f6b8ba69c7362063155b35833a00c2bd064f94d99367e2941a573aed4488f9a71a3b163d4b54
EBUILD pybugz-0.13-r2.ebuild 965 BLAKE2B 8291688cd717091efe0ae534f785c9b1804ed1d30325721b0a0ec3313d1b4f9b72961decb9e7acb5b44ce52f87b848e3090d1d49bc418e9348474f962b354536 SHA512 c2efd6481c354fe61a769532cce4813d6e38a21b3c8515fbd60dd36b560e55fffc017d45ae17b47963a9ceeb337618033fb266afa45db15328e6c962c16a012d
-EBUILD pybugz-9999.ebuild 960 BLAKE2B 165e4109fd0df11e26c971f7946a7302317739ba0ea45ce817049baaf3ecc6e8afe61a5e48e6023f3b2d726b4018d37f988d6289c110e9e70107d031031da55c SHA512 6b213967a66481ee6411ab1129e60734bb78b063f3afdf3751e7bf963980d63df71c1a6f7d00a72ec2ea4abfb5b8c58f9a3cc0d9f271367fb6f1cd024a3dff16
+EBUILD pybugz-0.13-r3.ebuild 905 BLAKE2B 845103542dbef7ca7139a5aefe785f7be6893cfc34a5fcf0f1fb3c7a1e846a81ea98d3951e208094767aa733870785677e5876d2b288a4c15c1e62a662fcaa35 SHA512 0f87fc006e2e5ad19177d459d7707c0e4a2af967c77f871ad51d6cd92044f10ea1750fd8498373ade4466ca79db795573dee4e4add4aea6d1cec75b8d6d21707
+EBUILD pybugz-9999.ebuild 905 BLAKE2B 845103542dbef7ca7139a5aefe785f7be6893cfc34a5fcf0f1fb3c7a1e846a81ea98d3951e208094767aa733870785677e5876d2b288a4c15c1e62a662fcaa35 SHA512 0f87fc006e2e5ad19177d459d7707c0e4a2af967c77f871ad51d6cd92044f10ea1750fd8498373ade4466ca79db795573dee4e4add4aea6d1cec75b8d6d21707
MISC metadata.xml 333 BLAKE2B 1028380ada32e4b505ccb80253788e29abb3330f182583fe7a2128cbe3f2f5dde2a719f8c66c17479a1adec918c2a83f1a3648707e970bb1338262a46bd8b790 SHA512 e203f5ef23a2ae071f8294719384b86dea97b205acb5637223c559af2c2e5ecf384a933c4475546dbc9f40d10b277b346b0bf3b2d4ec780fba087f59c7986ab0
diff --git a/www-client/pybugz/pybugz-0.13-r3.ebuild b/www-client/pybugz/pybugz-0.13-r3.ebuild
new file mode 100644
index 000000000000..17680b4e1e24
--- /dev/null
+++ b/www-client/pybugz/pybugz-0.13-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="readline(+),ssl(+)"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/williamh/pybugz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
+HOMEPAGE="https://github.com/williamh/pybugz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp contrib/bash-completion bugz
+
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
+}
diff --git a/www-client/pybugz/pybugz-9999.ebuild b/www-client/pybugz/pybugz-9999.ebuild
index 8f3124991403..17680b4e1e24 100644
--- a/www-client/pybugz/pybugz-9999.ebuild
+++ b/www-client/pybugz/pybugz-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="readline(+),ssl(+)"
@@ -11,7 +12,7 @@ if [ "${PV}" = "9999" ]; then
inherit git-r3
else
SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
fi
inherit bash-completion-r1 distutils-r1
@@ -22,9 +23,6 @@ HOMEPAGE="https://github.com/williamh/pybugz"
LICENSE="GPL-2"
SLOT="0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
python_install_all() {
distutils-r1_python_install_all
newbashcomp contrib/bash-completion bugz