summaryrefslogtreecommitdiff
path: root/www-client/netsurf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-client/netsurf/files
reinit the tree, so we can have metadata
Diffstat (limited to 'www-client/netsurf/files')
-rw-r--r--www-client/netsurf/files/netsurf-3.6-CFLAGS.patch67
-rw-r--r--www-client/netsurf/files/netsurf-3.6-conditionally-include-image-headers.patch31
-rw-r--r--www-client/netsurf/files/netsurf-3.6-gstreamer.patch31
-rw-r--r--www-client/netsurf/files/netsurf-3.6-pdf-writer.patch80
4 files changed, 209 insertions, 0 deletions
diff --git a/www-client/netsurf/files/netsurf-3.6-CFLAGS.patch b/www-client/netsurf/files/netsurf-3.6-CFLAGS.patch
new file mode 100644
index 000000000000..8004aa4c6206
--- /dev/null
+++ b/www-client/netsurf/files/netsurf-3.6-CFLAGS.patch
@@ -0,0 +1,67 @@
+--- netsurf-3.6/Makefile.defaults
++++ netsurf-3.6/Makefile.defaults
+@@ -96,12 +96,6 @@
+ # Valid options: YES, NO
+ NETSURF_FS_BACKING_STORE := NO
+
+-# Initial CFLAGS. Optimisation level etc. tend to be target specific.
+-CFLAGS :=
+-
+-# Initial CXXFLAGS. Optimisation level etc. tend to be target specific.
+-CXXFLAGS :=
+-
+ # Default installation/execution prefix
+ PREFIX ?= /usr/local
+
+--- netsurf-3.6/frontends/framebuffer/Makefile
++++ netsurf-3.6/frontends/framebuffer/Makefile
+@@ -20,7 +20,7 @@
+ CFLAGS += '-DNETSURF_FB_FONT_CURSIVE="$(NETSURF_FB_FONT_CURSIVE)"'
+ CFLAGS += '-DNETSURF_FB_FONT_FANTASY="$(NETSURF_FB_FONT_FANTASY)"'
+
+-CFLAGS += -std=c99 -g -Dsmall \
++CFLAGS += -std=c99 -Dsmall \
+ -D_BSD_SOURCE \
+ -D_DEFAULT_SOURCE \
+ -D_XOPEN_SOURCE=600 \
+--- netsurf-3.6/frontends/framebuffer/Makefile.defaults
++++ netsurf-3.6/frontends/framebuffer/Makefile.defaults
+@@ -3,7 +3,7 @@
+ # ----------------------------------------------------------------------------
+
+ # Optimisation levels
+-CFLAGS += -O2
++CFLAGS +=
+
+ # Framebuffer default surface provider.
+ # Valid values are: x, sdl, linux, vnc, able,
+--- netsurf-3.6/frontends/gtk/Makefile
++++ netsurf-3.6/frontends/gtk/Makefile
+@@ -33,7 +33,7 @@
+ endif
+
+
+-GTKCFLAGS := -std=c99 -Dgtk -Dnsgtk -g \
++GTKCFLAGS := -std=c99 -Dgtk -Dnsgtk \
+ $(GTKDEPFLAGS) \
+ -D_BSD_SOURCE \
+ -D_DEFAULT_SOURCE \
+--- netsurf-3.6/frontends/gtk/Makefile.defaults
++++ netsurf-3.6/frontends/gtk/Makefile.defaults
+@@ -39,4 +39,4 @@
+ NETSURF_GTK_MAJOR ?= 2
+
+ # Optimisation levels
+-CFLAGS += -O2
++CFLAGS +=
+--- netsurf-3.6/test/Makefile
++++ netsurf-3.6/test/Makefile
+@@ -105,7 +105,7 @@
+ COMMON_WARNFLAGS += -Wno-unused-parameter
+ endif
+
+-TESTCFLAGS := -std=c99 -g \
++TESTCFLAGS := -std=c99 \
+ $(COMMON_WARNFLAGS) \
+ -D_BSD_SOURCE \
+ -D_POSIX_C_SOURCE=200809L \
diff --git a/www-client/netsurf/files/netsurf-3.6-conditionally-include-image-headers.patch b/www-client/netsurf/files/netsurf-3.6-conditionally-include-image-headers.patch
new file mode 100644
index 000000000000..06754464cb6c
--- /dev/null
+++ b/www-client/netsurf/files/netsurf-3.6-conditionally-include-image-headers.patch
@@ -0,0 +1,31 @@
+--- netsurf-3.6/content/handlers/image/image.c
++++ netsurf-3.6/content/handlers/image/image.c
+@@ -27,14 +27,28 @@
+ #include "netsurf/content.h"
+ #include "desktop/gui_internal.h"
+
++#ifdef WITH_BMP
+ #include "image/bmp.h"
++#endif
++#ifdef WITH_GIF
+ #include "image/gif.h"
++#endif
+ #include "image/ico.h"
++#ifdef WITH_JPEG
+ #include "image/jpeg.h"
++#endif
++#ifdef WITH_NSSPRITE
+ #include "image/nssprite.h"
++#endif
++#ifdef WITH_PNG
+ #include "image/png.h"
++#endif
++#ifdef WITH_RSVG
+ #include "image/rsvg.h"
++#endif
++#ifdef WITH_NS_SVG
+ #include "image/svg.h"
++#endif
+ #include "image/image.h"
+
+ /**
diff --git a/www-client/netsurf/files/netsurf-3.6-gstreamer.patch b/www-client/netsurf/files/netsurf-3.6-gstreamer.patch
new file mode 100644
index 000000000000..6aca4f6abdf9
--- /dev/null
+++ b/www-client/netsurf/files/netsurf-3.6-gstreamer.patch
@@ -0,0 +1,31 @@
+--- netsurf-3.6/frontends/gtk/Makefile
++++ netsurf-3.6/frontends/gtk/Makefile
+@@ -16,7 +16,6 @@
+
+ # GTK and GLIB flags to disable depricated usage
+ GTKDEPFLAGS := -DG_DISABLE_SINGLE_INCLUDES \
+- -DG_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_SINGLE_INCLUDES \
+ -DGTK_MULTIHEAD_SAFE \
+ -DPANGO_DISABLE_DEPRECATED
+--- netsurf-3.6/content/handlers/image/video.c
++++ netsurf-3.6/content/handlers/image/video.c
+@@ -22,6 +22,8 @@
+ #include "content/content_protected.h"
+
+ #include "image/video.h"
++#include "utils/http/parameter.h"
++#include "content/llcache.h"
+
+ typedef struct nsvideo_content {
+ struct content base;
+--- netsurf-3.6/content/content_factory.h
++++ netsurf-3.6/content/content_factory.h
+@@ -25,6 +25,7 @@
+
+ #include "netsurf/content_type.h"
+ #include "utils/errors.h"
++#include "utils/utils.h"
+
+ #define CONTENT_FACTORY_REGISTER_TYPES(HNAME, HTYPELIST, HHANDLER) \
+ \
diff --git a/www-client/netsurf/files/netsurf-3.6-pdf-writer.patch b/www-client/netsurf/files/netsurf-3.6-pdf-writer.patch
new file mode 100644
index 000000000000..5824adc1ecbf
--- /dev/null
+++ b/www-client/netsurf/files/netsurf-3.6-pdf-writer.patch
@@ -0,0 +1,80 @@
+--- netsurf-3.6/desktop/font_haru.c
++++ netsurf-3.6/desktop/font_haru.c
+@@ -37,7 +37,7 @@
+ #include <hpdf.h>
+
+ #include "utils/nsoption.h"
+-#include "desktop/save_pdf/font_haru.h"
++#include "desktop/font_haru.h"
+ #include "desktop/font.h"
+ #include "utils/log.h"
+
+--- netsurf-3.6/desktop/save_pdf.c
++++ netsurf-3.6/desktop/save_pdf.c
+@@ -60,6 +60,8 @@
+ #include "utils/useragent.h"
+ #include "content/hlcache.h"
+ #include "utils/nsoption.h"
++#include "desktop/gui_misc.h"
++#include "desktop/gui_internal.h"
+ #include "netsurf/bitmap.h"
+
+ #include "netsurf/plotters.h"
+@@ -450,11 +452,6 @@
+
+ switch(content_get_type(content)){
+ /*Handle "embeddable" types of images*/
+- case CONTENT_JPEG:
+- image = HPDF_LoadJpegImageFromMem(pdf_doc,
+- (const HPDF_BYTE *) source_data,
+- source_size);
+- break;
+
+ /*Disabled until HARU PNG support will be more stable.
+
+@@ -700,7 +697,7 @@
+
+
+ #ifndef PDF_DEBUG
+- if (option_enable_PDF_compression)
++ if (nsoption_bool(enable_PDF_compression))
+ HPDF_SetCompressionMode(pdf_doc, HPDF_COMP_ALL); /*Compression on*/
+ #endif
+ HPDF_SetInfoAttr(pdf_doc, HPDF_INFO_CREATOR, user_agent_string());
+@@ -774,7 +771,7 @@
+ assert(settings->output != NULL);
+
+ /*Encryption on*/
+- if (option_enable_PDF_password)
++ if (nsoption_bool(enable_PDF_password))
+ guit->misc->pdf_password(&owner_pass, &user_pass,
+ (void *)settings->output);
+ else
+@@ -789,7 +786,7 @@
+ {
+ nserror res = NSERROR_OK;
+
+- if (option_enable_PDF_password && owner_pass != NULL ) {
++ if (nsoption_bool(enable_PDF_password) && owner_pass != NULL ) {
+ HPDF_SetPassword(pdf_doc, owner_pass, user_pass);
+ HPDF_SetEncryptionMode(pdf_doc, HPDF_ENCRYPT_R3, 16);
+ free(owner_pass);
+--- netsurf-3.6/frontends/gtk/scaffolding.c
++++ netsurf-3.6/frontends/gtk/scaffolding.c
+@@ -731,14 +731,14 @@
+
+ free(url_name);
+
+- strncpy(dirname, option_downloads_directory, PATH_MAX);
++ strncpy(dirname, nsoption_charp(downloads_directory), PATH_MAX);
+ strncat(dirname, "/", PATH_MAX - strlen(dirname));
+ dirname[PATH_MAX - 1] = '\0';
+
+ /* this way the scale used by PDF functions is synchronized with that
+ * used by the all-purpose print interface
+ */
+- haru_nsfont_set_scale((float)option_export_scale / 100);
++ haru_nsfont_set_scale((float)nsoption_int(export_scale) / 100);
+
+ save_dialog = gtk_file_chooser_dialog_new("Export to PDF", g->window,
+ GTK_FILE_CHOOSER_ACTION_SAVE,