summaryrefslogtreecommitdiff
path: root/www-client/httrack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 07:19:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 07:19:33 +0000
commit0bdb5244708888dfc364e30b08facc0a45281f78 (patch)
tree85a5d103ddb3f2e1434b2a741a77626999887328 /www-client/httrack
parent56767705335e747c2a8b3f3282e5c1a393352d54 (diff)
gentoo auto-resync : 29:11:2022 - 07:19:33
Diffstat (limited to 'www-client/httrack')
-rw-r--r--www-client/httrack/Manifest1
-rw-r--r--www-client/httrack/httrack-3.49.2-r3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/www-client/httrack/Manifest b/www-client/httrack/Manifest
index 0026e0d22912..3ad45dacd6c3 100644
--- a/www-client/httrack/Manifest
+++ b/www-client/httrack/Manifest
@@ -1,4 +1,5 @@
AUX httrack-3.48.13-minizip.patch 1519 BLAKE2B f8b1202dfc0c0222d2d81fea01d5cbd83db8492db83b9022a56464c194ca38e5f7f380babf73d3ad2b93c23b1f166c0fab735c411688bfe6ea9f4aea28343085 SHA512 e366ea5e93888afcacc1a5df29fd4a0a6a8ea7a0eb9659e4f017a97a93c97ef12d286ed50762ee8e53a328d4cc2307bda169ae3c4d247919faec0010e1f1a10d
DIST httrack-3.49.2.tar.gz 1835116 BLAKE2B 4073b70268bcea8acf0a9ac10deed14764ccd405c82f1b9f48dc74d3dbef130161234b59e70e72305a195d21155474831e8359eea9b96d275481a69b1c1ff561 SHA512 84a13a776b278533f7f0635ebd764387c3399b01c0644d8af9b46fc8112dc3c6e568c17969d4f6c2db32b5474344c39f86cf51957c09eb807ebe305a554ba5c8
EBUILD httrack-3.49.2-r2.ebuild 1661 BLAKE2B 5197d8ec76b8a1e66be3bb130d62f8ea791440c129b558e18ea86ca8d6f590505d2f3b6e8a2ad7100fa42f11fc18dfee2d7d3928baf841c989a045d872fb35d1 SHA512 42d5b1cda4dc4d1a8382ea4f30dcbd6a59ea2a6a575dd791371d658faadc2d7010b27d156eeeb0c3a1c908004ee3a03b5876ffb50fa51d759d6ae4446707362c
+EBUILD httrack-3.49.2-r3.ebuild 1655 BLAKE2B d1a32e89f0f6ac2cf32866341b1c87ce69fa9cd4349ca2e877fb231d100eeaab20cbe25d1e0efcabc1369274613aa881258997ee9a22f6f7337d42e7709c2ef1 SHA512 b277c6a991daf6460666b5acfa27c99a72a6f46c52073a932059656b2733cc9b5a7a7eaf776be56785386d10abdeda853892a4abfae1ed6515e42d87f1510e4a
MISC metadata.xml 214 BLAKE2B 8e2573ceb0f0d2978152cf3e74f8c5b2dfd695ce86214d006fc541976a863704b7a380b753c32b62430566f6352bb87b883ffa26919e742a63043e4ec99aecd3 SHA512 cce34978e61906565e3493a183fe9561783fea6ad3d6a8370c10aab541d54f333babd13bdd34516362f0006cf1811c0ea5c039c8c962a8fb6a3dc59e9b5c2a2c
diff --git a/www-client/httrack/httrack-3.49.2-r3.ebuild b/www-client/httrack/httrack-3.49.2-r3.ebuild
new file mode 100644
index 000000000000..b306e0d666ba
--- /dev/null
+++ b/www-client/httrack/httrack-3.49.2-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools xdg-utils
+
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="https://www.httrack.com/"
+SRC_URI="https://mirror.httrack.com/historical/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
+ >=dev-libs/openssl-1.1.0:=
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README greetings.txt history.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.48.13-minizip.patch
+)
+
+src_prepare() {
+ default
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/732272).
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing.
+ if [[ "$(get_libdir)" != lib ]]; then
+ grep -wq '{ZLIB_HOME}/lib' m4/check_zlib.m4 || die
+ sed "s,{ZLIB_HOME}/lib,{ZLIB_HOME}/$(get_libdir)," -i m4/check_zlib.m4 || die
+ grep -w '{ZLIB_HOME}/lib' m4/check_zlib.m4 && die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Make webhttrack work despite FEATURES=nodoc cutting
+ # all of /usr/share/doc/ away (bug #493376)
+ if has nodoc ${FEATURES} ; then
+ dodir /usr/share/${PF}/
+ mv "${D}"/usr/share/{doc/,}${PF}/html || die
+
+ rm "${D}"/usr/share/${PN}/html || die
+ dosym ../../${PF}/html /usr/share/${PN}/html
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}