summaryrefslogtreecommitdiff
path: root/www-client/httrack/httrack-3.49.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /www-client/httrack/httrack-3.49.2-r2.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'www-client/httrack/httrack-3.49.2-r2.ebuild')
-rw-r--r--www-client/httrack/httrack-3.49.2-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/www-client/httrack/httrack-3.49.2-r2.ebuild b/www-client/httrack/httrack-3.49.2-r2.ebuild
new file mode 100644
index 000000000000..f513c18ae018
--- /dev/null
+++ b/www-client/httrack/httrack-3.49.2-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils xdg-utils
+
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="https://www.httrack.com/"
+SRC_URI="https://mirror.httrack.com/historical/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="libressl static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl )
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README greetings.txt history.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.48.13-minizip.patch
+)
+
+src_configure() {
+ econf $(use_enable static-libs static) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # Make webhttrack work despite FEATURES=nodoc cutting
+ # all of /usr/share/doc/ away (bug #493376)
+ if has nodoc ${FEATURES} ; then
+ dodir /usr/share/${PF}/
+ mv "${D}"/usr/share/{doc/,}${PF}/html || die
+
+ rm "${D}"/usr/share/${PN}/html || die
+ dosym ../../${PF}/html /usr/share/${PN}/html
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}