summaryrefslogtreecommitdiff
path: root/www-client/httrack/httrack-3.49.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /www-client/httrack/httrack-3.49.2-r2.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'www-client/httrack/httrack-3.49.2-r2.ebuild')
-rw-r--r--www-client/httrack/httrack-3.49.2-r2.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/www-client/httrack/httrack-3.49.2-r2.ebuild b/www-client/httrack/httrack-3.49.2-r2.ebuild
index 11539e76c331..a6bded23cc64 100644
--- a/www-client/httrack/httrack-3.49.2-r2.ebuild
+++ b/www-client/httrack/httrack-3.49.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit eutils xdg-utils
+inherit autotools multilib eutils xdg-utils
DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
HOMEPAGE="https://www.httrack.com/"
@@ -26,6 +26,20 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.48.13-minizip.patch
)
+src_prepare() {
+ default
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/732272).
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing.
+ grep -wq '{ZLIB_HOME}/lib' m4/check_zlib.m4 || die
+ sed "s,{ZLIB_HOME}/lib,{ZLIB_HOME}/$(get_libdir)," -i m4/check_zlib.m4 || die
+ grep -w '{ZLIB_HOME}/lib' m4/check_zlib.m4 && die
+
+ eautoreconf
+}
+
src_configure() {
econf $(use_enable static-libs static)
}