summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-84.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /www-client/firefox/firefox-84.0.ebuild
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'www-client/firefox/firefox-84.0.ebuild')
-rw-r--r--www-client/firefox/firefox-84.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-84.0.ebuild b/www-client/firefox/firefox-84.0.ebuild
index 6d3e1b6e40d8..e2bb2e858214 100644
--- a/www-client/firefox/firefox-84.0.ebuild
+++ b/www-client/firefox/firefox-84.0.ebuild
@@ -521,6 +521,7 @@ src_prepare() {
src_configure() {
# Show flags set at the beginning
einfo "Current CFLAGS: ${CFLAGS}"
+ einfo "Current CXXFLAGS: ${CXXFLAGS}"
einfo "Current LDFLAGS: ${LDFLAGS}"
einfo "Current RUSTFLAGS: ${RUSTFLAGS}"
@@ -767,6 +768,11 @@ src_configure() {
if [[ -n ${disable_elf_hack} ]] ; then
mozconfig_add_options_ac 'elf-hack is broken when using Clang' --disable-elf-hack
fi
+ elif tc-is-gcc ; then
+ if ver_test $(gcc-fullversion) -ge 10 ; then
+ einfo "Forcing -fno-tree-loop-vectorize to workaround GCC bug, see bug 758446 ..."
+ append-cxxflags -fno-tree-loop-vectorize
+ fi
fi
# Additional ARCH support
@@ -813,6 +819,7 @@ src_configure() {
# Show flags we will use
einfo "Build CFLAGS: ${CFLAGS}"
+ einfo "Build CXXFLAGS: ${CXXFLAGS}"
einfo "Build LDFLAGS: ${LDFLAGS}"
einfo "Build RUSTFLAGS: ${RUSTFLAGS}"