summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-119.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 14:48:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 14:48:06 +0100
commit3529f1bf2739399905cd55b27c7609459bfc069f (patch)
tree030ac4ab6cc001de1876af06bc97f8d480c911f1 /www-client/firefox/firefox-119.0.ebuild
parent0fcaac21e786bd7911b1e8f436cd885c5e2f6437 (diff)
gentoo auto-resync : 27:10:2023 - 14:48:06
Diffstat (limited to 'www-client/firefox/firefox-119.0.ebuild')
-rw-r--r--www-client/firefox/firefox-119.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-119.0.ebuild b/www-client/firefox/firefox-119.0.ebuild
index 13d0e1b403ba..fb9a32336ba3 100644
--- a/www-client/firefox/firefox-119.0.ebuild
+++ b/www-client/firefox/firefox-119.0.ebuild
@@ -1062,10 +1062,15 @@ src_configure() {
# elf-hack
if use amd64 || use x86 ; then
- if use clang ; then
- mozconfig_add_options_ac 'relr elf-hack with clang' --enable-elf-hack=relr
+ if tc-ld-is-mold ; then
+ # relr-elf-hack is currently broken with mold, bgo#916259
+ mozconfig_add_options_ac 'disable elf-hack with mold linker' --disable-elf-hack
else
- mozconfig_add_options_ac 'legacy elf-hack with gcc' --enable-elf-hack=legacy
+ if use clang ; then
+ mozconfig_add_options_ac 'relr elf-hack with clang' --enable-elf-hack=relr
+ else
+ mozconfig_add_options_ac 'legacy elf-hack with gcc' --enable-elf-hack=legacy
+ fi
fi
else
mozconfig_add_options_ac 'disable elf-hack on non-supported arches' --disable-elf-hack