summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-109.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 17:55:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 17:55:18 +0000
commit0bc41c955151f7b962f67f03e18e580620f91bd6 (patch)
tree834073a4e0c66ae35e5b891a763832075aad475f /www-client/firefox/firefox-109.0.ebuild
parente54e6bf2ec8cc0fb912bffefee5b3d22cd3fcd9c (diff)
gentoo auto-resync : 17:01:2023 - 17:55:17
Diffstat (limited to 'www-client/firefox/firefox-109.0.ebuild')
-rw-r--r--www-client/firefox/firefox-109.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/www-client/firefox/firefox-109.0.ebuild b/www-client/firefox/firefox-109.0.ebuild
index 1243ab1925e5..62bacfdb5569 100644
--- a/www-client/firefox/firefox-109.0.ebuild
+++ b/www-client/firefox/firefox-109.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-FIREFOX_PATCHSET="firefox-109-patches-01j.tar.xz"
+FIREFOX_PATCHSET="firefox-109-patches-02j.tar.xz"
LLVM_MAX_SLOT=15
@@ -646,9 +646,6 @@ src_prepare() {
einfo "Removing pre-built binaries ..."
find "${S}"/third_party -type f \( -name '*.so' -o -name '*.o' \) -print -delete || die
- # Clearing crate checksums where we have applied patches
- moz_clear_vendor_checksums bindgen
-
# Create build dir
BUILD_DIR="${WORKDIR}/${PN}_build"
mkdir -p "${BUILD_DIR}" || die
@@ -736,7 +733,6 @@ src_configure() {
--disable-gpsd \
--disable-install-strip \
--disable-parental-controls \
- --disable-real-time-tracing \
--disable-strip \
--disable-tests \
--disable-updater \
@@ -894,7 +890,10 @@ src_configure() {
mozconfig_use_enable debug
if use debug ; then
mozconfig_add_options_ac '+debug' --disable-optimize
+ mozconfig_add_options_ac '+debug' --enable-real-time-tracing
else
+ mozconfig_add_options_ac 'Gentoo defaults' --disable-real-time-tracing
+
if is-flag '-g*' ; then
if use clang ; then
mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')