summaryrefslogtreecommitdiff
path: root/www-client/elinks/elinks-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /www-client/elinks/elinks-9999.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'www-client/elinks/elinks-9999.ebuild')
-rw-r--r--www-client/elinks/elinks-9999.ebuild58
1 files changed, 19 insertions, 39 deletions
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index f608a19718e3..871ec4ab5abb 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -6,12 +6,11 @@ PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
inherit autotools git-r3 python-any-r1
-EGIT_REPO_URI="git://repo.or.cz/elinks.git"
+EGIT_REPO_URI="https://github.com/rkd77/felinks"
MY_P="${P/_/}"
DESCRIPTION="Advanced and well-established text-mode web browser"
HOMEPAGE="http://elinks.or.cz/"
-SRC_URI="https://dev.gentoo.org/~spock/portage/distfiles/elinks-0.10.4.conf.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -24,22 +23,22 @@ DEPEND="
${PYTHON_DEPS}
brotli? ( app-arch/brotli )
bzip2? ( >=app-arch/bzip2-1.0.2 )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- xml? ( >=dev-libs/expat-1.95.4 )
- X? ( x11-libs/libX11 x11-libs/libXt )
- zlib? ( >=sys-libs/zlib-1.1.4 )
- lua? ( >=dev-lang/lua-5:0= )
gpm? ( >=sys-libs/ncurses-5.2:0= >=sys-libs/gpm-1.20.0-r5 )
guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated,discouraged] )
idn? ( net-dns/libidn )
+ javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )
+ lua? ( >=dev-lang/lua-5:0= )
perl? ( dev-lang/perl:= )
ruby? ( dev-lang/ruby:* dev-ruby/rubygems:* )
samba? ( net-fs/samba )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
tre? ( dev-libs/tre )
- javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )"
+ X? ( x11-libs/libX11 x11-libs/libXt )
+ xml? ( >=dev-libs/expat-1.95.4 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
RDEPEND="${DEPEND}"
PATCHES=(
@@ -54,21 +53,6 @@ src_unpack() {
src_prepare() {
default
- cd "${WORKDIR}" || die
- eapply "${FILESDIR}"/${PN}-0.10.4.conf-syscharset.diff
- mv ${PN}-0.10.4.conf ${PN}.conf || die
- if ! use ftp ; then
- sed -i -e 's/\(.*protocol.ftp.*\)/# \1/' ${PN}.conf || die
- fi
- sed -i -e 's/\(.*set protocol.ftp.use_epsv.*\)/# \1/' ${PN}.conf || die
- cd "${S}" || die
-
- # Regenerate acinclude.m4 - based on autogen.sh.
- cat > acinclude.m4 <<- _EOF || die
- dnl Automatically generated from config/m4/ files.
- dnl Do not modify!
- _EOF
- cat config/m4/*.m4 >> acinclude.m4 || die
sed -i -e 's/-Werror//' configure* || die
eautoreconf
@@ -100,26 +84,26 @@ src_configure() {
--enable-true-color \
--enable-html-highlight \
$(use_with gpm) \
- $(use_with zlib) \
$(use_with brotli) \
$(use_with bzip2 bzlib) \
- $(use_with X x) \
- $(use_with lua) \
$(use_with guile) \
- $(use_with perl) \
- $(use_with ruby) \
$(use_with idn) \
$(use_with javascript spidermonkey) \
+ $(use_with lua) \
+ $(use_with perl) \
+ $(use_with ruby) \
$(use_with tre) \
+ $(use_with X x) \
+ $(use_with zlib) \
$(use_enable bittorrent) \
- $(use_enable nls) \
- $(use_enable ipv6) \
+ $(use_enable finger) \
$(use_enable ftp) \
$(use_enable gopher) \
+ $(use_enable ipv6) \
+ $(use_enable mouse) \
+ $(use_enable nls) \
$(use_enable nntp) \
- $(use_enable finger) \
$(use_enable samba smb) \
- $(use_enable mouse) \
$(use_enable xml xbel) \
${myconf}
}
@@ -132,7 +116,6 @@ src_install() {
emake V=1 DESTDIR="${D}" install
insinto /etc/elinks
- doins "${WORKDIR}"/elinks.conf
newins contrib/keybind-full.conf keybind-full.sample
newins contrib/keybind.conf keybind.conf.sample
@@ -148,9 +131,6 @@ src_install() {
}
pkg_postinst() {
- einfo "This ebuild provides a default config for ELinks."
- einfo "Please check /etc/elinks/elinks.conf"
- einfo
einfo "You may want to convert your html.cfg and links.cfg of"
einfo "Links or older ELinks versions to the new ELinks elinks.conf"
einfo "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"