summaryrefslogtreecommitdiff
path: root/www-client/elinks/elinks-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /www-client/elinks/elinks-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'www-client/elinks/elinks-9999.ebuild')
-rw-r--r--www-client/elinks/elinks-9999.ebuild39
1 files changed, 23 insertions, 16 deletions
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index 0d10ee080caf..15f8ced61462 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads"
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
inherit autotools git-r3 python-any-r1
EGIT_REPO_URI="https://github.com/rkd77/felinks"
@@ -14,23 +15,27 @@ HOMEPAGE="http://elinks.or.cz/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm guile idn ipv6
+IUSE="bittorrent brotli bzip2 debug finger ftp gopher gpm gnutls guile idn ipv6
javascript libressl lua +mouse nls nntp perl ruby samba ssl tre unicode X xml zlib"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
- brotli? ( app-arch/brotli )
+ brotli? ( app-arch/brotli:= )
bzip2? ( >=app-arch/bzip2-1.0.2 )
gpm? ( >=sys-libs/ncurses-5.2:0= >=sys-libs/gpm-1.20.0-r5 )
guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated] )
- idn? ( net-dns/libidn )
- javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )
+ idn? ( net-dns/libidn:= )
+ javascript? ( dev-lang/spidermonkey:17= )
lua? ( >=dev-lang/lua-5:0= )
perl? ( dev-lang/perl:= )
ruby? ( dev-lang/ruby:* dev-ruby/rubygems:* )
samba? ( net-fs/samba )
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ gnutls? ( net-libs/gnutls:= )
)
tre? ( dev-libs/tre )
X? ( x11-libs/libX11 x11-libs/libXt )
@@ -41,7 +46,8 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-parallel-make.patch
- )
+ "${FILESDIR}"/${PN}-0.13.4-ruby-gcc10.patch
+)
src_unpack() {
default
@@ -70,7 +76,7 @@ src_configure() {
$(use_with guile)
$(use_with idn)
$(use_with javascript spidermonkey)
- $(use_with lua)
+ --with-luapkg=$(usev lua)
$(use_with perl)
$(use_with ruby)
$(use_with tre)
@@ -94,11 +100,12 @@ src_configure() {
myconf+=( --enable-fastmem )
fi
- # NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
- # As GNUTLS is not yet 100% stable and its support in ELinks is not so well
- # tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
if use ssl ; then
- myconf+=( --with-openssl="${EPREFIX}"/usr )
+ if use gnutls ; then
+ myconf+=( --with-gnutls )
+ else
+ myconf+=( --with-openssl="${EPREFIX}"/usr )
+ fi
else
myconf+=( --without-openssl --without-gnutls )
fi