summaryrefslogtreecommitdiff
path: root/www-client/dillo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /www-client/dillo
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/Manifest1
-rw-r--r--www-client/dillo/dillo-9999.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/www-client/dillo/Manifest b/www-client/dillo/Manifest
index 6dae34cf8fb1..b710d92a28cb 100644
--- a/www-client/dillo/Manifest
+++ b/www-client/dillo/Manifest
@@ -3,4 +3,5 @@ DIST dillo-3.0.5.tar.bz2 734472 BLAKE2B c8a7ac3a875740d2d64269b0d368e6f9395c89a5
DIST dillo.png 6135 BLAKE2B 63aa76000934123420d0704317309639bf5dcd22c61b09406a7ec67018b17044a417209954d67f22e2000b0871d315a25388bacffab9599230fc9615877a2f08 SHA512 cfc9bcf1bfd0fff7fc625c7d288c92d0f33418b963a4e344844fd2bcb33823b3215a8a1a86162dcd1c614eea2323bb361c11bd8bd15859b771c63943c1b40833
EBUILD dillo-3.0.5-r1.ebuild 1378 BLAKE2B 2f4a547df425e6431e270ca0804c594558ae3706b484a3ded36e4b1cb58f81232d4652b9fca0253168ef64b2f47a83e26f48f147f8be2b5560315848823184d3 SHA512 297faacaa17346813d430322cee1f6b2a4840e9e62c63687e8a90eb777e348e67fe5a9e660a3f1f2e5796c81c78bd389779b6001bbeb100e20554e510121d321
EBUILD dillo-3.0.5.ebuild 1309 BLAKE2B 2c885ee9ace3a10e754592728d8078829ab7eef5f9c12690ca87f0fb74c17fb5b836b70258785e8ffd93a4dc6995d04461a8e5df5e5a313b1d2b23707cf1757c SHA512 92c0238f5de326169c92c1e5fa575f2f844ff75cd7c1d6253f988ebd82f3d36483ede339a8f77985e6b934ce2c04dccf919f449e2272a2a1f0e3319ea1780911
+EBUILD dillo-9999.ebuild 1292 BLAKE2B 59cb6f16543ad305c747f7b29b0b037b8aa1aaf48bc35d9f71fa11c147683dca3e360be037a36b0b534c1ab24ca135e91f00ffe2db5beb294c63b2e008e144f6 SHA512 f2c4b5dcd11c9e184b74b8e8b8d94cc43665822a616bb0ee6bb70b364f71145aa6a1dd30711e0a76dcd22cd91ffb2182bfaa83c2033e8b30dd0ee1a608b78b6f
MISC metadata.xml 282 BLAKE2B f175ac89f79f8ebbe3bc806c0c4a8169e2a4b88708d85928db9a23dacecd92a2acb1c5d1f6a49a2f8375288aa4b2db910af8c325557540ba665c37a17e773721 SHA512 06c94ffb49c985c4344b170b902427ca9ce0c23b6d68330af227ab1771794f8e8b6d0ef75b5f69293c8ef0d3264c8799e1389ccdf8dfbe7c665c6477c07479e4
diff --git a/www-client/dillo/dillo-9999.ebuild b/www-client/dillo/dillo-9999.ebuild
new file mode 100644
index 000000000000..0d478f4ab15d
--- /dev/null
+++ b/www-client/dillo/dillo-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils mercurial multilib toolchain-funcs
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="https://www.dillo.org/"
+SRC_URI="mirror://gentoo/${PN}.png"
+EHG_REPO_URI="https://hg.dillo.org/dillo"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc +gif ipv6 +jpeg +png ssl"
+
+RDEPEND="
+ >=x11-libs/fltk-1.3
+ sys-libs/zlib
+ jpeg? ( virtual/jpeg:0 )
+ png? ( >=media-libs/libpng-1.2:0 )
+ ssl? ( net-libs/mbedtls )
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}2-inbuf.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gif) \
+ $(use_enable ipv6) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable ssl) \
+ --docdir="/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ dodir /etc
+ default
+
+ use doc && dohtml html/*
+ dodoc AUTHORS ChangeLog README NEWS
+ dodoc doc/*.txt doc/README
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Dillo
+}
+
+pkg_postinst() {
+ elog "Dillo has installed a default configuration into /etc/dillo/dillorc"
+ elog "You can copy this to ~/.dillo/ and customize it"
+}