summaryrefslogtreecommitdiff
path: root/www-client/chromium/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-03 22:54:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-03 22:54:31 +0100
commitb0ebd12de22226fd7b69140ccd700efda3eb5fa6 (patch)
treeefcf8d59607e53b8bf2fb453629b05bea28cc3ce /www-client/chromium/files
parent99547b97ff461f107e03ed5323b6286a66677bce (diff)
gentoo auto-resync : 03:08:2023 - 22:54:30
Diffstat (limited to 'www-client/chromium/files')
-rw-r--r--www-client/chromium/files/chromium-109-system-openh264.patch20
-rw-r--r--www-client/chromium/files/chromium-113-gcc-13-0001-vulkanmemoryallocator.patch10
-rw-r--r--www-client/chromium/files/chromium-113-swiftshader-cstdint.patch40
-rw-r--r--www-client/chromium/files/chromium-114-compiler.patch171
-rw-r--r--www-client/chromium/files/chromium-114-iwyu-gcc-13.patch75
-rw-r--r--www-client/chromium/files/chromium-114-sigsegv-dom.patch73
6 files changed, 0 insertions, 389 deletions
diff --git a/www-client/chromium/files/chromium-109-system-openh264.patch b/www-client/chromium/files/chromium-109-system-openh264.patch
deleted file mode 100644
index 6be816b305b4..000000000000
--- a/www-client/chromium/files/chromium-109-system-openh264.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/build/linux/unbundle/openh264.gn
-+++ b/build/linux/unbundle/openh264.gn
-@@ -2,6 +2,7 @@
- # Use of this source code is governed by a BSD-style license that can be
- # found in the LICENSE file.
-
-+import("//build/buildflag_header.gni")
- import("//build/config/linux/pkg_config.gni")
- import("//build/shim_headers.gni")
-
-@@ -34,3 +35,9 @@ source_set("encoder") {
- deps = [ ":openh264_shim" ]
- public_configs = [ ":config" ]
- }
-+
-+buildflag_header("buildflags") {
-+ header = "buildflags.h"
-+ header_dir = "third_party/openh264"
-+ flags = [ "OPENH264_API_WELS=1" ]
-+}
diff --git a/www-client/chromium/files/chromium-113-gcc-13-0001-vulkanmemoryallocator.patch b/www-client/chromium/files/chromium-113-gcc-13-0001-vulkanmemoryallocator.patch
deleted file mode 100644
index 28372caeb72c..000000000000
--- a/www-client/chromium/files/chromium-113-gcc-13-0001-vulkanmemoryallocator.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/third_party/vulkan-deps/vulkan-validation-layers/src/layers/external/vma/vk_mem_alloc.h
-+++ b/third_party/vulkan-deps/vulkan-validation-layers/src/layers/external/vma/vk_mem_alloc.h
-@@ -2579,6 +2579,7 @@ VMA_CALL_PRE void VMA_CALL_POST vmaFreeStatsString(
- #undef VMA_IMPLEMENTATION
-
- #include <cstdint>
-+#include <cstdio>
- #include <cstdlib>
- #include <cstring>
- #include <utility>
diff --git a/www-client/chromium/files/chromium-113-swiftshader-cstdint.patch b/www-client/chromium/files/chromium-113-swiftshader-cstdint.patch
deleted file mode 100644
index 6c04f54996da..000000000000
--- a/www-client/chromium/files/chromium-113-swiftshader-cstdint.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From ecefa6c6596982616fa1f564fcee363ef8533808 Mon Sep 17 00:00:00 2001
-From: Stephan Hartmann <stha09@googlemail.com>
-Date: Wed, 03 May 2023 12:01:36 +0200
-Subject: [PATCH] IWYU: add cstdint for uintptr_t in llvm-10.0 Signals.h
-
-Upstream commit:
-
- From ff1681ddb303223973653f7f5f3f3435b48a1983 Mon Sep 17 00:00:00 2001
- From: Sergei Trofimovich <slyich@gmail.com>
- Date: Mon, 23 May 2022 08:03:23 +0100
- Subject: [PATCH] [Support] Add missing <cstdint> header to Signals.h
-
- Without the change llvm build fails on this week's gcc-13 snapshot as:
-
- [ 0%] Building CXX object lib/Support/CMakeFiles/LLVMSupport.dir/Signals.cpp.o
- In file included from llvm/lib/Support/Signals.cpp:14:
- llvm/include/llvm/Support/Signals.h:119:8: error: variable or field 'CleanupOnSignal' declared void
- 119 | void CleanupOnSignal(uintptr_t Context);
- | ^~~~~~~~~~~~~~~
-
-Change-Id: Iabe0256d86012e7887e295815aa6cfd50694459a
-Reviewed-on: https://swiftshader-review.googlesource.com/c/SwiftShader/+/71608
-Reviewed-by: Shahbaz Youssefi <syoussefi@google.com>
-Kokoro-Result: kokoro <noreply+kokoro@google.com>
-Tested-by: Shahbaz Youssefi <syoussefi@google.com>
-Commit-Queue: Shahbaz Youssefi <syoussefi@google.com>
----
-
-diff --git a/third_party/llvm-10.0/llvm/include/llvm/Support/Signals.h b/third_party/llvm-10.0/llvm/include/llvm/Support/Signals.h
-index e0a18e7..148216b 100644
---- a/third_party/swiftshader/third_party/llvm-10.0/llvm/include/llvm/Support/Signals.h
-+++ b/third_party/swiftshader/third_party/llvm-10.0/llvm/include/llvm/Support/Signals.h
-@@ -14,6 +14,7 @@
- #ifndef LLVM_SUPPORT_SIGNALS_H
- #define LLVM_SUPPORT_SIGNALS_H
-
-+#include <cstdint>
- #include <string>
-
- namespace llvm {
diff --git a/www-client/chromium/files/chromium-114-compiler.patch b/www-client/chromium/files/chromium-114-compiler.patch
deleted file mode 100644
index f6a6b708da6f..000000000000
--- a/www-client/chromium/files/chromium-114-compiler.patch
+++ /dev/null
@@ -1,171 +0,0 @@
-This patches the compiler settings for chromium to remove
-clang-specific settings, among other things.
-
-Just do a `git apply --reject` to the unpacked chromium source when
-it inevitably needs to be updated between versions.
-
---- a/build/config/compiler/BUILD.gn
-+++ b/build/config/compiler/BUILD.gn
-@@ -289,9 +289,7 @@ config("compiler") {
-
- configs += [
- # See the definitions below.
-- ":clang_revision",
- ":rustc_revision",
-- ":compiler_cpu_abi",
- ":compiler_codegen",
- ":compiler_deterministic",
- ]
-@@ -732,7 +730,6 @@ config("compiler") {
- # toolchain has this flag.
- # We only use one version of LLVM within a build so there's no need to
- # upgrade debug info, which can be expensive since it runs the verifier.
-- ldflags += [ "-Wl,-mllvm,-disable-auto-upgrade-debug-info" ]
- }
- }
-
-@@ -1406,27 +1403,6 @@ config("compiler_deterministic") {
- }
- }
-
--config("clang_revision") {
-- if (is_clang && clang_base_path == default_clang_base_path) {
-- update_args = [
-- "--print-revision",
-- "--verify-version=$clang_version",
-- ]
-- if (llvm_force_head_revision) {
-- update_args += [ "--llvm-force-head-revision" ]
-- }
-- clang_revision = exec_script("//tools/clang/scripts/update.py",
-- update_args,
-- "trim string")
--
-- # This is here so that all files get recompiled after a clang roll and
-- # when turning clang on or off. (defines are passed via the command line,
-- # and build system rebuild things when their commandline changes). Nothing
-- # should ever read this define.
-- defines = [ "CR_CLANG_REVISION=\"$clang_revision\"" ]
-- }
--}
--
- config("rustc_revision") {
- if (rustc_revision != "") {
- # Similar to the above config, this is here so that all files get recompiled
-@@ -1716,7 +1692,7 @@ config("chromium_code") {
- defines = [ "_HAS_NODISCARD" ]
- }
- } else {
-- cflags = [ "-Wall" ]
-+ cflags = []
- if (treat_warnings_as_errors) {
- cflags += [ "-Werror" ]
-
-@@ -1725,10 +1701,6 @@ config("chromium_code") {
- # well.
- ldflags = [ "-Werror" ]
- }
-- if (is_clang) {
-- # Enable extra warnings for chromium_code when we control the compiler.
-- cflags += [ "-Wextra" ]
-- }
-
- if (treat_warnings_as_errors) {
- # Turn rustc warnings into the "deny" lint level, which produce compiler
-@@ -1746,16 +1718,6 @@ config("chromium_code") {
- "__STDC_FORMAT_MACROS",
- ]
-
-- if (!is_debug && !using_sanitizer && current_cpu != "s390x" &&
-- current_cpu != "s390" && current_cpu != "ppc64" &&
-- current_cpu != "mips" && current_cpu != "mips64" &&
-- current_cpu != "riscv64" && current_cpu != "loong64") {
-- # Non-chromium code is not guaranteed to compile cleanly with
-- # _FORTIFY_SOURCE. Also, fortified build may fail when optimizations are
-- # disabled, so only do that for Release build.
-- defines += [ "_FORTIFY_SOURCE=2" ]
-- }
--
- if (is_apple) {
- cflags_objc = [ "-Wimplicit-retain-self" ]
- cflags_objcc = [ "-Wimplicit-retain-self" ]
-@@ -2120,7 +2082,8 @@ config("default_stack_frames") {
- }
-
- # Default "optimization on" config.
--config("optimize") {
-+config("optimize") { }
-+config("xoptimize") {
- if (is_win) {
- if (chrome_pgo_phase != 2) {
- # Favor size over speed, /O1 must be before the common flags.
-@@ -2179,7 +2142,8 @@ config("optimize") {
- }
-
- # Turn off optimizations.
--config("no_optimize") {
-+config("no_optimize") { }
-+config("xno_optimize") {
- if (is_win) {
- cflags = [
- "/Od", # Disable optimization.
-@@ -2219,7 +2183,8 @@ config("no_optimize") {
- # Turns up the optimization level. On Windows, this implies whole program
- # optimization and link-time code generation which is very expensive and should
- # be used sparingly.
--config("optimize_max") {
-+config("optimize_max") { }
-+config("xoptimize_max") {
- if (is_nacl && is_nacl_irt) {
- # The NaCl IRT is a special case and always wants its own config.
- # Various components do:
-@@ -2252,7 +2217,8 @@ config("optimize_max") {
- #
- # TODO(crbug.com/621335) - rework how all of these configs are related
- # so that we don't need this disclaimer.
--config("optimize_speed") {
-+config("optimize_speed") { }
-+config("xoptimize_speed") {
- if (is_nacl && is_nacl_irt) {
- # The NaCl IRT is a special case and always wants its own config.
- # Various components do:
-@@ -2278,7 +2244,8 @@ config("optimize_speed") {
- }
- }
-
--config("optimize_fuzzing") {
-+config("optimize_fuzzing") { }
-+config("xoptimize_fuzzing") {
- cflags = [ "-O1" ] + common_optimize_on_cflags
- rustflags = [ "-Copt-level=1" ]
- ldflags = common_optimize_on_ldflags
-@@ -2403,7 +2370,8 @@ config("win_pdbaltpath") {
- }
-
- # Full symbols.
--config("symbols") {
-+config("symbols") { }
-+config("xsymbols") {
- rustflags = []
- if (is_win) {
- if (is_clang) {
-@@ -2546,7 +2514,8 @@ config("symbols") {
- # Minimal symbols.
- # This config guarantees to hold symbol for stack trace which are shown to user
- # when crash happens in unittests running on buildbot.
--config("minimal_symbols") {
-+config("minimal_symbols") { }
-+config("xminimal_symbols") {
- if (is_win) {
- # Functions, files, and line tables only.
- cflags = []
-@@ -2620,7 +2589,8 @@ config("minimal_symbols") {
- # This configuration contains function names only. That is, the compiler is
- # told to not generate debug information and the linker then just puts function
- # names in the final debug information.
--config("no_symbols") {
-+config("no_symbols") { }
-+config("xno_symbols") {
- if (is_win) {
- ldflags = [ "/DEBUG" ]
-
diff --git a/www-client/chromium/files/chromium-114-iwyu-gcc-13.patch b/www-client/chromium/files/chromium-114-iwyu-gcc-13.patch
deleted file mode 100644
index 564a9ee75843..000000000000
--- a/www-client/chromium/files/chromium-114-iwyu-gcc-13.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From 75c57b5f810d6ac6f393459d2884877c7fcf774c Mon Sep 17 00:00:00 2001
-From: Bruno Pitrus <brunopitrus@hotmail.com>
-Date: Mon, 05 Jun 2023 21:22:55 +0000
-Subject: [PATCH] IWYU: Add missing standard includes for GCC13
-
-Bug: 957519
-Change-Id: Ie327653083173b41dfd5a456f82ccb490c305c26
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/4547709
-Commit-Queue: Nico Weber <thakis@chromium.org>
-Auto-Submit: Bruno Pitrus <brunopitrus@hotmail.com>
-Reviewed-by: Nico Weber <thakis@chromium.org>
-Reviewed-by: Eric Orth <ericorth@chromium.org>
-Cr-Commit-Position: refs/heads/main@{#1153468}
----
-
-diff --git a/base/cpu.h b/base/cpu.h
-index 10450e9..2ac00e9 100644
---- a/base/cpu.h
-+++ b/base/cpu.h
-@@ -5,6 +5,7 @@
- #ifndef BASE_CPU_H_
- #define BASE_CPU_H_
-
-+#include <cstdint>
- #include <string>
-
- #include "base/base_export.h"
-diff --git a/components/services/app_service/public/cpp/intent_filter.h b/components/services/app_service/public/cpp/intent_filter.h
-index 9c83ccf..48724963 100644
---- a/components/services/app_service/public/cpp/intent_filter.h
-+++ b/components/services/app_service/public/cpp/intent_filter.h
-@@ -5,6 +5,7 @@
- #ifndef COMPONENTS_SERVICES_APP_SERVICE_PUBLIC_CPP_INTENT_FILTER_H_
- #define COMPONENTS_SERVICES_APP_SERVICE_PUBLIC_CPP_INTENT_FILTER_H_
-
-+#include <memory>
- #include <set>
- #include <string>
- #include <utility>
-diff --git a/components/services/app_service/public/cpp/permission.h b/components/services/app_service/public/cpp/permission.h
-index 82d323a..ede8540 100644
---- a/components/services/app_service/public/cpp/permission.h
-+++ b/components/services/app_service/public/cpp/permission.h
-@@ -5,6 +5,7 @@
- #ifndef COMPONENTS_SERVICES_APP_SERVICE_PUBLIC_CPP_PERMISSION_H_
- #define COMPONENTS_SERVICES_APP_SERVICE_PUBLIC_CPP_PERMISSION_H_
-
-+#include <memory>
- #include <utility>
- #include <vector>
-
-diff --git a/components/viz/common/view_transition_element_resource_id.h b/components/viz/common/view_transition_element_resource_id.h
-index 17ae568..44f980f 100644
---- a/components/viz/common/view_transition_element_resource_id.h
-+++ b/components/viz/common/view_transition_element_resource_id.h
-@@ -7,6 +7,7 @@
-
- #include <stdint.h>
-
-+#include <cstdint>
- #include <string>
- #include <vector>
-
-diff --git a/net/cert/pki/string_util.h b/net/cert/pki/string_util.h
-index b18f716..7340408 100644
---- a/net/cert/pki/string_util.h
-+++ b/net/cert/pki/string_util.h
-@@ -9,6 +9,7 @@
-
- #include <stdint.h>
-
-+#include <cstdint>
- #include <string_view>
- #include <vector>
-
diff --git a/www-client/chromium/files/chromium-114-sigsegv-dom.patch b/www-client/chromium/files/chromium-114-sigsegv-dom.patch
deleted file mode 100644
index fe4c2809693c..000000000000
--- a/www-client/chromium/files/chromium-114-sigsegv-dom.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-https://chromium.googlesource.com/chromium/src.git/+/2af2d08972d14d5bdd91e0515eb5b15b4444aee9
-blink::HTMLMediaElement::ShouldReusePlayer: avoid dereferencing a potentally NULL domWindow
-
-The domWindow() method of the Document class can potentially return nullptr
-as noted in renderer/core/dom/document.h
-
-> // A document may or may not have a browsing context
-> // (https://html.spec.whatwg.org/#browsing-context). A document with a browsing
-> // context is created by navigation, and has a non-null domWindow(), GetFrame(),
-> // Loader(), etc., and is visible to the user. It will have a valid
-> // GetExecutionContext(), which will be equal to domWindow(). If the Document
-> // constructor receives a DocumentInit created WithDocumentLoader(), it will
-> // have a browsing context.
-> // Documents created by all other APIs do not have a browsing context. These
-> // Documents still have a valid GetExecutionContext() (i.e., the domWindow() of
-> // the Document in which they were created), so they can still access
-> // script, but return null for domWindow(), GetFrame() and Loader(). Generally,
-> // they should not downcast the ExecutionContext to a LocalDOMWindow and access
-> // the properties of the window directly.
-
-Upon checking further, the offending document returns null for GetFrame() and
-Loader() aswell so this was likely just an oversight and no invariants are being
-violated
-
-Introduced in https://chromium-review.googlesource.com/c/chromium/src/+/4202152
-
-More details https://bugs.chromium.org/p/chromium/issues/detail?id=1447388
-
-Fixed: 1447388
-Change-Id: I85a6ef52baaac0ec7f5ec188d5d5bb2c518a8ecd
-Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/4546610
-Reviewed-by: Fredrik Söderquist <fs@opera.com>
-Commit-Queue: Fredrik Söderquist <fs@opera.com>
-Cr-Commit-Position: refs/heads/main@{#1147184}
-
---- a/AUTHORS
-+++ b/AUTHORS
-
-@@ -1012,6 +1012,7 @@
- Prashant Hiremath <prashhir@cisco.com>
- Prashant Nevase <prashant.n@samsung.com>
- Prashant Patil <prashant.patil@imgtec.com>
-+Pratham <prathamIN@proton.me>
- Praveen Akkiraju <praveen.anp@samsung.com>
- Preeti Nayak <preeti.nayak@samsung.com>
- Pritam Nikam <pritam.nikam@samsung.com>
-
---- a/third_party/blink/renderer/core/html/media/html_media_element.cc
-+++ b/third_party/blink/renderer/core/html/media/html_media_element.cc
-
-@@ -648,6 +648,11 @@
-
- bool HTMLMediaElement::ShouldReusePlayer(Document& old_document,
- Document& new_document) const {
-+ // A NULL frame implies a NULL domWindow, so just check one of them
-+ if (!old_document.GetFrame() || !new_document.GetFrame()) {
-+ return false;
-+ }
-+
- // Don't reuse player if the Document Picture-in-Picture API is disabled for
- // both documents.
- if (!RuntimeEnabledFeatures::DocumentPictureInPictureAPIEnabled(
-@@ -657,10 +662,6 @@
- return false;
- }
-
-- if (!old_document.GetFrame() || !new_document.GetFrame()) {
-- return false;
-- }
--
- auto* new_origin = new_document.GetFrame()
- ->LocalFrameRoot()
- .GetSecurityContext()