summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-22 23:18:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-22 23:18:20 +0100
commit820b3cf4687f358703c643bacf3e5a06ccfa4402 (patch)
tree9cb7c40b4ec609b7d07a8ec876bdd3207d132bb9 /www-apps
parentf66a06e8f9736ea679bc3e95d8c8e90ff7c3f466 (diff)
gentoo auto-resync : 22:09:2023 - 23:18:20
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/Manifest.gzbin13455 -> 13458 bytes
-rw-r--r--www-apps/icingaweb2/Manifest2
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.12.0.ebuild80
3 files changed, 82 insertions, 0 deletions
diff --git a/www-apps/Manifest.gz b/www-apps/Manifest.gz
index 721da71040db..142e105fc48b 100644
--- a/www-apps/Manifest.gz
+++ b/www-apps/Manifest.gz
Binary files differ
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 9f3553b67409..e82238f0317a 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,4 +1,6 @@
DIST icingaweb2-2.11.4.tar.gz 11381515 BLAKE2B e524d04fd027377685826e1e3ff4a73efb040f8736d35fa496cf190a69dc2e6fedd82f678d5994d66a450efaff77764fd6a9504823ba17897506ff3d923566d8 SHA512 3012e75c35f3070a5dfcb356ed499f247651c99b7f39faf1917ade4568f5ba15a2820ff63cab2583748cdb7d158f86b7b87bf8f4c934d3bd6526929dd57e1eae
+DIST icingaweb2-2.12.0.tar.gz 6354699 BLAKE2B a3d5af224a85278dbc244877fc8699617ff770a82e56f65c1e642eb23afd883b01d445d479319e9376b9a45e97d4ba028305c2773623b75464b19b1c00c12e72 SHA512 8e03c80ae0f4730307f606bcfed57978fea59d7917f2d505b063c29e05d913e047b6975bfc56673c0e71464a09578983d63a88c8efd35b1c80abb0d15384c275
EBUILD icingaweb2-2.11.4-r1.ebuild 2437 BLAKE2B 87e8e5cc1c5683d1a79915030e9bd3f19fa9b9e8ace11bf886d7d5ad2949881b7155546dfcaa295afb9c0d512369798327d5184a9b6b21c6d66d24e0cd3315bd SHA512 cefa272a1f1f0fe8f561036ebf214ebc43035e999a6f4d728b19880714183128fe15186983eb0f95486060b61ecca0ac0aacff84a342ca2da9600da0245ea6fe
+EBUILD icingaweb2-2.12.0.ebuild 2439 BLAKE2B f2133f8a710ac57cfa1461d2699aeb1346f70690f9155bf3db99248cef5a55cddb2b4945c35133fa0e29a624ee814c19ae286ab647abf11202a46c4fba3eea46 SHA512 7b92d046da4d6614a33b18106b4d7a5e76c8c8ee1be7e85d8035bfbde664a807a625b61f3759bd2c8969d41163f3b28ba599c8b717a1137058ea311a4997445b
EBUILD icingaweb2-9999.ebuild 2439 BLAKE2B f2133f8a710ac57cfa1461d2699aeb1346f70690f9155bf3db99248cef5a55cddb2b4945c35133fa0e29a624ee814c19ae286ab647abf11202a46c4fba3eea46 SHA512 7b92d046da4d6614a33b18106b4d7a5e76c8c8ee1be7e85d8035bfbde664a807a625b61f3759bd2c8969d41163f3b28ba599c8b717a1137058ea311a4997445b
MISC metadata.xml 444 BLAKE2B bf24467286f442770ed78cb298cd0fc1d37786b06e85bbc4b20a8c750764e7a831828ebc9b7872772f0a286b12cb67491cb1f84f189cf00e2ec59a6b921e760f SHA512 55e57997695e09ad9cc8448030e8470a0e39a1cbc610f70e29c2a68a4f287e54cb816b0cd1ceec611112849ba97225a60560b67368fb3a6ed68a73a728d61d83
diff --git a/www-apps/icingaweb2/icingaweb2-2.12.0.ebuild b/www-apps/icingaweb2/icingaweb2-2.12.0.ebuild
new file mode 100644
index 000000000000..9103daa5bbe2
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.12.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.1[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ >=dev-libs/icinga-php-library-0.8.1
+ >=dev-libs/icinga-php-thirdparty-0.11.0
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+ fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}