summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
commit6a7029e0f7370d4d5dfe9e31cc2719a870482392 (patch)
tree28c6c747114eaedfd2db81f86ac2ff3d7d13111e /www-apps
parent5e41a38157bb40e8513e8e34426e85faba672fe7 (diff)
gentoo auto-resync : 15:06:2024 - 00:09:17
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/Manifest.gzbin13468 -> 13465 bytes
-rw-r--r--www-apps/rutorrent/Manifest2
-rw-r--r--www-apps/rutorrent/rutorrent-4.3.3.ebuild71
3 files changed, 73 insertions, 0 deletions
diff --git a/www-apps/Manifest.gz b/www-apps/Manifest.gz
index 6784cd57e5d2..5493727d0163 100644
--- a/www-apps/Manifest.gz
+++ b/www-apps/Manifest.gz
Binary files differ
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 9c8f6f19293d..42000b9e5c5b 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,4 +1,6 @@
DIST rutorrent-4.2.10.tar.gz 2362233 BLAKE2B ea2b1b928e1a7c933ad6e85f5a18810d3f4bf11911da2926e26ba0329b54049dee24a456d0dedd98d106b3b9b460c791eae65a222cbe54ac0c2a49634b6b65a8 SHA512 b57e95591b835fd8d0c0e9acdf9c23dbaf6a37542c46397794da625edd02524af508510e0396308ddfe024d37c92e493134a13aae9dd28c5c642cdbd8d9264a5
+DIST rutorrent-4.3.3.tar.gz 2377736 BLAKE2B ae07dce8c13268403a47ef20a3920228028578991b7325b808885e4576e4883859eb49dff6e6d0d0750ed1b58e900c6b8f4c646018b1b16ca5d0d919e3011971 SHA512 0301f512f8adb86a332dacac200c83cf49f0d532eb5e5206b137587a219914591932a801e9c711af60b1e91a430ed09ec99157c2a558cdf80828828e70eb0cb7
EBUILD rutorrent-4.2.10.ebuild 1823 BLAKE2B 3ccbc5bce6c2bed8328f4911409350e50fda8dbe393069b857bc39ebf75368905dab5fdac75c5a2f2ca16b88bc67e801c029e02874182bfd26bb46c747ee0102 SHA512 35fe365ca6478306b9a15f3b24f8a89434b52bf788d53ff308907cb51bf7c2ca04ee0bf84f7c83dc41435b8f5a5d7027295457d77778b66d14742c7828865b9e
+EBUILD rutorrent-4.3.3.ebuild 1823 BLAKE2B 9dc18b75f6832abdda6b903d30944922f5a5e4f100eadc81de128f82e2a68b838729e0bbf9466af1217c82c6d6b9e8e472836abf4c1751e73968e258b0d7c553 SHA512 dbfadca5a4122cf458a862a8578e7f0d3a8a7e7d0a06faafa94d744ec41c2af1a3e6140381990a2ffcf4c93bd3a0c5b59a0fb12219d4a35e63986343175f7b31
EBUILD rutorrent-9999.ebuild 1823 BLAKE2B 3ccbc5bce6c2bed8328f4911409350e50fda8dbe393069b857bc39ebf75368905dab5fdac75c5a2f2ca16b88bc67e801c029e02874182bfd26bb46c747ee0102 SHA512 35fe365ca6478306b9a15f3b24f8a89434b52bf788d53ff308907cb51bf7c2ca04ee0bf84f7c83dc41435b8f5a5d7027295457d77778b66d14742c7828865b9e
MISC metadata.xml 478 BLAKE2B 51373fb574d5353a98f9ae5fc190448d9659fbc6b99a4e631f490b410ebfd9840507d62a08214045350aeb965f834432500412e5ceb146552f02c53141c4cdec SHA512 c253d933bd4cf0edb8516fc0f851f98543a27c422bcd5179d1ca95da28e37df6ea30c27d3685592374103b1af84ca5c98a6ea1060a20267e4485e38f9e54e5d2
diff --git a/www-apps/rutorrent/rutorrent-4.3.3.ebuild b/www-apps/rutorrent/rutorrent-4.3.3.ebuild
new file mode 100644
index 000000000000..97453fadf5c8
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.3.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}