summaryrefslogtreecommitdiff
path: root/www-apps/zeppelin-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
commitaa3411e241a201d53a2689766fe419f2756819f3 (patch)
treecc19adfde0a10aab1ab566c8dfe3c1616e5cc390 /www-apps/zeppelin-bin
parentb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (diff)
gentoo resync : 24.03.2019
Diffstat (limited to 'www-apps/zeppelin-bin')
-rw-r--r--www-apps/zeppelin-bin/Manifest4
-rw-r--r--www-apps/zeppelin-bin/files/zeppelin.init.d19
-rw-r--r--www-apps/zeppelin-bin/metadata.xml11
-rw-r--r--www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild40
4 files changed, 74 insertions, 0 deletions
diff --git a/www-apps/zeppelin-bin/Manifest b/www-apps/zeppelin-bin/Manifest
new file mode 100644
index 000000000000..101d3c2c0a20
--- /dev/null
+++ b/www-apps/zeppelin-bin/Manifest
@@ -0,0 +1,4 @@
+AUX zeppelin.init.d 492 BLAKE2B f6a551375b34ffc8ab0c2f5fe259614a8dd7024e6578919943755121d796ffc815678133446ce65b0c7eadbe18bcd0441327e29fb4cd8226f949a769f1f7e1bd SHA512 a70788870d766256c3e515748d9680e19ea0a574b81c47e5a4456a81179701db551079e2a066e5dba69c3db5d10509250780b6e54f2b43f5fc8602252292ab1b
+DIST zeppelin-bin-0.8.1.tgz 992975720 BLAKE2B 13bae89054a5be0570d0550cfc875d989de66dcdc6fe2aa3c8b71b452782d8cf2c8f6cf030b47f1b9050899912f75136cef7d9ef1b80c8957ad8a260fc7050c5 SHA512 b8302b36acc5cc8859f4341329bcb4d038bbb91d4493be191606df94da08a2fa37940958ceae507e6cdbe22fc338111ac9bee580cb41ee74198911469552df02
+EBUILD zeppelin-bin-0.8.1.ebuild 918 BLAKE2B 37a1afb39b64bc5a04c4eb8c4a8b51cf1b161e17244fdbd7d9be5c7f1f4e65e72c7c343aed1e2a7ef1f3f99a9b5b4e0c27af6bf590851726ed01f33aff61c685 SHA512 14a66d142d0f83c2e295c6e1072d33bfc600f1dcde07e39fc731a7d9fa8f8eb00058e83e00d3679b6687908c33e71f67e61a75b98c41c604899f2309df57782d
+MISC metadata.xml 331 BLAKE2B d3c2a6f490848f29f26ce31bb281d8b5ccb39463be72a40228a91ab5e4b91f5797dba1a6b5e789f977a3485c4b0fdc6bd7c112d95b527546688ecf91a1c60291 SHA512 0ae77f77f2563a7885f4d037432ac7b75728af9144fc58dd9069a4dc8f8b74ad9425600d43d39e6801dc225d3f4f6fc93cb393ba3c2cdd40d6788d2d22d184f0
diff --git a/www-apps/zeppelin-bin/files/zeppelin.init.d b/www-apps/zeppelin-bin/files/zeppelin.init.d
new file mode 100644
index 000000000000..03ddd6beabc7
--- /dev/null
+++ b/www-apps/zeppelin-bin/files/zeppelin.init.d
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Web-based interactive data analytics notebook launcher"
+command="/opt/zeppelin/bin/zeppelin-daemon.sh"
+logfile="/var/log/zeppelin/zeppelin-gentoo.log"
+
+start() {
+ ebegin "Starting Apache Zeppelin ..."
+ bash $command start >> $logfile
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Apache Zeppelin ..."
+ bash $command stop >> $logfile
+ eend $?
+}
diff --git a/www-apps/zeppelin-bin/metadata.xml b/www-apps/zeppelin-bin/metadata.xml
new file mode 100644
index 000000000000..5c85a44abf8e
--- /dev/null
+++ b/www-apps/zeppelin-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">apache/zeppelin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild b/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild
new file mode 100644
index 000000000000..6b80c178e624
--- /dev/null
+++ b/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 user
+
+MY_PN="zeppelin"
+MY_P="${MY_PN}-${PV}-bin-all"
+
+DESCRIPTION="Web-based interactive data analytics notebook launcher"
+HOMEPAGE="https://zeppelin.apache.org"
+SRC_URI="mirror://apache/zeppelin/${MY_PN}-${PV}/${MY_P}.tgz -> ${P}.tgz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+INSTALL_DIR="/opt/${P}"
+
+pkg_setup() {
+ enewgroup zeppelin
+ enewuser zeppelin -1 /bin/sh /home/zeppelin zeppelin
+}
+
+src_install() {
+ keepdir /var/log/zeppelin
+ fowners -R zeppelin:zeppelin /var/log/zeppelin
+
+ newinitd "${FILESDIR}/zeppelin.init.d" zeppelin
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP * "${ED}/${INSTALL_DIR}" || die
+ dosym "${ED}/${INSTALL_DIR}" /opt/zeppelin
+ fowners -R zeppelin:zeppelin "${INSTALL_DIR}"
+}